summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDiego Elio 'Flameeyes' Pettenò <flameeyes@gmail.com>2009-05-15 22:43:56 +0200
committerDiego Elio 'Flameeyes' Pettenò <flameeyes@gmail.com>2009-05-15 22:43:56 +0200
commit0de6877934cd70874b7baa7e9ab416c43b7f9fc5 (patch)
tree8616cb408380fe15baf66c94c4e678cedbdf8ac5 /configure.ac
parent862a05f8c8b9d02520c904e4eff0740f1c56f181 (diff)
Don't use == for comparison in tests. Fix build with non-bash shells.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 5 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 16e6648c..37b9fc52 100644
--- a/configure.ac
+++ b/configure.ac
@@ -608,30 +608,30 @@ AC_ARG_WITH(
[database],
AS_HELP_STRING([--with-database=auto|tdb|gdbm],[Choose database backend.]),[],[with_database=auto])
-if test "x${with_database}" == "xauto" -o "x${with_database}" == "xtdb" ; then
+if test "x${with_database}" = "xauto" -o "x${with_database}" = "xtdb" ; then
PKG_CHECK_MODULES(TDB, [ tdb ],
[
HAVE_TDB=1
with_database=tdb
], [
- if test "x${with_database}" == "xtdb" ; then
+ if test "x${with_database}" = "xtdb" ; then
AC_MSG_ERROR([*** tdb not found])
fi
])
fi
-if test "x${with_database}" == "xauto" -o "x${with_database}" == "xgdbm" ; then
+if test "x${with_database}" = "xauto" -o "x${with_database}" = "xgdbm" ; then
have_gdbm=yes
AC_CHECK_LIB(gdbm, gdbm_open, [], [have_gdbm=no])
AC_CHECK_HEADERS(gdbm.h, [], [have_gdbm=no])
- if test "x${have_gdbm}" == "xyes" ; then
+ if test "x${have_gdbm}" = "xyes" ; then
HAVE_GDBM=1
GDBM_CFLAGS=
GDBM_LIBS=-lgdbm
with_database=gdbm
- elif test "x${with_database}" == "xgdbm"; then
+ elif test "x${with_database}" = "xgdbm"; then
AC_MSG_ERROR([*** gdbm not found])
fi
fi