summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorPierre Ossman <ossman@cendio.se>2006-01-11 14:36:02 +0000
committerPierre Ossman <ossman@cendio.se>2006-01-11 14:36:02 +0000
commit72316ccf9c8c7fec6fbd5d190852a61168002b24 (patch)
tree60a33f3e324caf491195fd06055921fbed4b19b1 /configure.ac
parent2623edcc4222884d57ce161e4ab0ba86feb8a2b8 (diff)
Many (FSF and Sun at least) have interpreted the C99 standard in a way
that int64_t and similar types are only defined on 64 bit platforms. Using -std=gnu99 lifts this rather silly restriction. The HAVE_NETLINK define is not generated anywhere in our configure. So it was rather pointless to use it for any test. git-svn-id: file:///home/lennart/svn/public/pulseaudio/trunk@450 fefdeb5f-60dc-0310-8127-8f9354f1896f
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac26
1 files changed, 3 insertions, 23 deletions
diff --git a/configure.ac b/configure.ac
index 8a87928b..bfe6ecd1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -63,29 +63,9 @@ test_gcc_flag() {
# If using GCC specify some additional parameters
if test "x$GCC" = "xyes" ; then
- DESIRED_FLAGS="-Wall -W -Wextra -pedantic -pipe -Wformat -Wold-style-definition -Wdeclaration-after-statement -Wfloat-equal -Wmissing-declarations -Wmissing-prototypes -Wstrict-prototypes -Wredundant-decls -Wmissing-noreturn -Wshadow -Wendif-labels -Wpointer-arith -Wbad-function-cast -Wcast-qual -Wcast-align -Wwrite-strings -Winline -Wno-unused-parameter"
-
- if test "x$HAVE_NETLINK" = "xyes" ; then
- # Test whether rtnetlink.h can be included when compiled with -std=c99
- # some distributions (e.g. archlinux) have broken headers that dont
- # define __u64 with -std=c99
- AC_MSG_CHECKING([checking whether rtnetlink.h can be included with -std=c99])
- OLDCFLAGS="$CFLAGS"
- CFLAGS="-std=c99"
- AC_TRY_COMPILE([#include <linux/rtnetlink.h>], [],
- use_stdc99=yes, use_stdc99=no)
-
- if test x"$use_stdc99" = xyes; then
- DESIRED_FLAGS="-std=c99 $DESIRED_FLAGS"
- AC_MSG_RESULT([yes])
- else
- AC_MSG_RESULT([no])
- fi
-
- CFLAGS="$OLDCFLAGS"
- else
- DESIRED_FLAGS="-std=c99 $DESIRED_FLAGS"
- fi
+ # We use gnu99 instead of c99 because many have interpreted the standard
+ # in a way that int64_t isn't defined on non-64 bit platforms.
+ DESIRED_FLAGS="-std=gnu99 -Wall -W -Wextra -pedantic -pipe -Wformat -Wold-style-definition -Wdeclaration-after-statement -Wfloat-equal -Wmissing-declarations -Wmissing-prototypes -Wstrict-prototypes -Wredundant-decls -Wmissing-noreturn -Wshadow -Wendif-labels -Wpointer-arith -Wbad-function-cast -Wcast-qual -Wcast-align -Wwrite-strings -Winline -Wno-unused-parameter"
for flag in $DESIRED_FLAGS ; do
AC_MSG_CHECKING([whether $CC accepts $flag])