summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorColin Guthrie <cguthrie@mandriva.org>2009-07-16 17:41:25 +0100
committerColin Guthrie <cguthrie@mandriva.org>2009-07-16 17:41:25 +0100
commit7e4509f9e5a1add8bd7efaf69cefd35a291b6253 (patch)
treeddfb9a54a174b36ef7299dfb369f266ceeff9501 /configure.ac
parent61fefd67dab01011d97a06b7e3dd51101d5f5749 (diff)
parent84200b423ebfa7e2dad9b1b65f64eac7bf3d2114 (diff)
Merge commit 'flameeyes/master'
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 00121f82..cc7f674a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -113,6 +113,12 @@ CC_CHECK_LDFLAGS([${tmp_ldflag}],
[VERSIONING_LDFLAGS='-Wl,-version-script=$(srcdir)/map-file'])
AC_SUBST([VERSIONING_LDFLAGS])
+dnl Use immediate (now) bindings; avoids the funky re-call in itself
+dnl the -z now syntax is lifted from Sun's linker and works with GNU's too
+dnl other linkes might be added later
+CC_CHECK_LDFLAGS([-Wl,-z,now], [IMMEDIATE_LDFLAGS="-Wl,-z,now"])
+AC_SUBST([IMMEDIATE_LDFLAGS])
+
dnl Check for the proper way to build libraries that have no undefined
dnl symbols; on some hosts this needs to be avoided but the macro
dnl takes care of it.
@@ -388,6 +394,7 @@ AC_SEARCH_LIBS([timer_create], [rt])
# BSD
AC_SEARCH_LIBS([connect], [socket])
+AC_SEARCH_LIBS([backtrace], [execinfo])
# Non-standard