summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDiego Elio 'Flameeyes' Pettenò <flameeyes@gmail.com>2009-06-24 17:39:25 +0200
committerLennart Poettering <lennart@poettering.net>2009-06-29 17:40:01 +0200
commita4703ce7e8be3be6dfa3511f5b4356720589754a (patch)
treedc5c0844d9c868c3426fa97ca4fe54026747bbe8 /configure.ac
parente61795ce53dd2ac08ca50470f7238442aed72aef (diff)
Check for and use flags to reject undefined symbols in libraries.
Make sure that all the PulseAudio modules are built properly without outstanding undefined symbols: if the undefined symbols are found, reject link.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 06539b3b..931b57d5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -117,6 +117,11 @@ CC_CHECK_LDFLAGS([${tmp_ldflag}],
[VERSIONING_LDFLAGS='-Wl,-version-script=$(srcdir)/map-file'])
AC_SUBST([VERSIONING_LDFLAGS])
+dnl Check for the proper way to build libraries that have no undefined
+dnl symbols; on some hosts this needs to be avoided but the macro
+dnl takes care of it.
+CC_NOUNDEFINED
+
dnl Check whether to build tests by default (as compile-test) or not
AC_ARG_ENABLE([default-build-tests],
AS_HELP_STRING([--disable-default-build-tests], [Build test programs only during make check]))