summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDaniel Mack <daniel@caiaq.de>2009-12-10 10:32:57 +0800
committerDaniel Mack <daniel@caiaq.de>2009-12-16 16:11:39 +0800
commit0ccc7afcd8cf77346568ffbf9a8b2e0b3ce2ea0e (patch)
treeebce217e5de597dc55e2290d4b5a1f89513cef2b /configure.ac
parent7732421a27870a832d7121bc8342503f2fbf3c2a (diff)
osx: add native zeroconf implementation via Bonjour
Avahi and dbus is too heavy for OSX just for the sake of publishing our services via mDNS/Zeroconf. Apple has its own Zeroconf implementation called Bonjour, and this patch adds a module that implements service announcement with that API. All data gathering is copied from module-zeroconf-publish.c, but unfortunately the code there is too specifically made for avahi, so I couldn't factor it out to reuse it.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 11af89b0..6b540e4a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -423,8 +423,12 @@ if test "x$os_is_darwin" = "x1" ; then
AC_MSG_RESULT([ok])
AC_DEFINE([HAVE_CLOCK_GETTIME], 1, [Using clock_gettime() replacement])
+ HAVE_BONJOUR=1
fi
+AC_SUBST(HAVE_BONJOUR)
+AM_CONDITIONAL([HAVE_BONJOUR], [test "x$HAVE_BONJOUR" = x1])
+
#### Check for functions ####
# ISO