summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorPierre Ossman <ossman@cendio.se>2006-05-24 13:22:16 +0000
committerPierre Ossman <ossman@cendio.se>2006-05-24 13:22:16 +0000
commit2843b1a318aa1a01da465031d713ca2238b39d4c (patch)
tree8a604556fd5fbcdffaeb3b7bf0a93bbbb78b7dc6 /configure.ac
parentc4328cdfddb16cf43ae4037b087cf2c58d7c531d (diff)
Remove the exceedingly anal warnings. It's impossible to write a non-trivial
C program and not trigger these. git-svn-id: file:///home/lennart/svn/public/pulseaudio/trunk@958 fefdeb5f-60dc-0310-8127-8f9354f1896f
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index fadc0219..18dba96d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -87,7 +87,7 @@ if test "x$GCC" = "xyes" ; then
# We use gnu99 instead of c99 because many have interpreted the standard
# in a way that int64_t isn't defined on non-64 bit platforms.
- DESIRED_FLAGS="-std=gnu99 -Wall -W -Wextra -pedantic -pipe -Wformat -Wold-style-definition -Wdeclaration-after-statement -Wfloat-equal -Wmissing-declarations -Wmissing-prototypes -Wstrict-prototypes -Wredundant-decls -Wmissing-noreturn -Wshadow -Wendif-labels -Wpointer-arith -Wbad-function-cast -Wcast-qual -Wcast-align -Wwrite-strings -Winline -Wno-unused-parameter"
+ DESIRED_FLAGS="-std=gnu99 -Wall -W -Wextra -pedantic -pipe -Wformat -Wold-style-definition -Wdeclaration-after-statement -Wfloat-equal -Wmissing-declarations -Wmissing-prototypes -Wstrict-prototypes -Wredundant-decls -Wmissing-noreturn -Wshadow -Wendif-labels -Wpointer-arith -Wcast-align -Wwrite-strings -Winline -Wno-unused-parameter"
for flag in $DESIRED_FLAGS ; do
AC_MSG_CHECKING([whether $CC accepts $flag])