summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorColin Guthrie <cguthrie@mandriva.org>2010-05-29 19:33:54 +0100
committerColin Guthrie <cguthrie@mandriva.org>2010-09-18 12:04:09 +0100
commit38778117f8e03f32ec5af8684a1013cc7807d66d (patch)
tree07d696e8bae6ea5f6c77c60c93942c2b4e52770e /configure.ac
parent2ecd764662174bf81b90cfa057104dec103bfeec (diff)
x11: Partially convert to XCB.
This commit mostly converts the X11 handling to XCB. There are still some uses of XLib to deal with the X11 session handling modules, however all client-side code should now be free of XLib and thus this should fix Bug #799 Note that this removes the screen-based changes by Leszek Koltunski in 65e80, however this will be restored in due course.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index a3551f06..5d69c924 100644
--- a/configure.ac
+++ b/configure.ac
@@ -531,7 +531,7 @@ AC_ARG_ENABLE([x11],
[x11=auto])
if test "x${x11}" != xno ; then
- PKG_CHECK_MODULES(X11, [ x11 ice sm xtst ],
+ PKG_CHECK_MODULES(X11, [ x11-xcb ice sm xtst xcb-atom ],
HAVE_X11=1,
[
HAVE_X11=0