summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2007-11-11 23:18:19 +0000
committerLennart Poettering <lennart@poettering.net>2007-11-11 23:18:19 +0000
commit5054f3623ff82ab0c263e15c47779b0caa841b29 (patch)
tree08b9db24040d969fd5da278e44bc2bd80d7ce366 /configure.ac
parente8092bede9c2c9daac6c6035ca7a130b2c9a7e5b (diff)
add new fun module that automatically mutes your audio devices when you leave with your bluetooth phone, and unmutes when you come back
git-svn-id: file:///home/lennart/svn/public/pulseaudio/trunk@2048 fefdeb5f-60dc-0310-8127-8f9354f1896f
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac36
1 files changed, 36 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f6e548bc..b5834f0f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -789,6 +789,36 @@ AC_SUBST(HAL_LIBS)
AC_SUBST(HAVE_HAL)
AM_CONDITIONAL([HAVE_HAL], [test "x$HAVE_HAL" = x1])
+#### BlueZ support (optional) ####
+
+AC_ARG_ENABLE([bluez],
+ AC_HELP_STRING([--disable-bluez], [Disable optional BlueZ support]),
+ [
+ case "${enableval}" in
+ yes) bluez=yes ;;
+ no) bluez=no ;;
+ *) AC_MSG_ERROR(bad value ${enableval} for --disable-bluez) ;;
+ esac
+ ],
+ [bluez=auto])
+if test "x${bluez}" != xno ; then
+ PKG_CHECK_MODULES(BLUEZ, [ bluez >= 3.0 ],
+ HAVE_BLUEZ=1,
+ [
+ HAVE_BLUEZ=0
+ if test "x$bluez" = xyes ; then
+ AC_MSG_ERROR([*** BLUEZ support not found])
+ fi
+ ])
+else
+ HAVE_BLUEZ=0
+fi
+
+AC_SUBST(BLUEZ_CFLAGS)
+AC_SUBST(BLUEZ_LIBS)
+AC_SUBST(HAVE_BLUEZ)
+AM_CONDITIONAL([HAVE_BLUEZ], [test "x$HAVE_BLUEZ" = x1])
+
#### D-Bus support (optional) ####
AC_ARG_ENABLE([dbus],
@@ -1028,6 +1058,11 @@ if test "x${HAVE_LIBSAMPLERATE}" = "x1" ; then
ENABLE_LIBSAMPLERATE=yes
fi
+ENABLE_BLUEZ=no
+if test "x${HAVE_BLUEZ}" = "x1" ; then
+ ENABLE_BLUEZ=yes
+fi
+
echo "
---{ $PACKAGE_NAME $VERSION }---
@@ -1048,6 +1083,7 @@ echo "
Enable Async DNS: ${ENABLE_LIBASYNCNS}
Enable LIRC: ${ENABLE_LIRC}
Enable HAL: ${ENABLE_HAL}
+ Enable BlueZ: ${ENABLE_BLUEZ}
Enable TCP Wrappers: ${ENABLE_TCPWRAP}
Enable libsamplerate: ${ENABLE_LIBSAMPLERATE}
System User: ${PA_SYSTEM_USER}