summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2006-05-16 17:54:33 +0000
committerLennart Poettering <lennart@poettering.net>2006-05-16 17:54:33 +0000
commit55215597c43e81da1560894645dcd27642cc0a47 (patch)
treef0e8da9842ab7df4b255cd37e8dcc5a384f62dc8 /configure.ac
parent929899015d23f4af2b19b7b7c56fd8bbd50f519f (diff)
* add new configure option --with-module-dir=
* drop version suffix from soname of libpolyp and friends * add version suffix by default to $(modlibexecdir) git-svn-id: file:///home/lennart/svn/public/pulseaudio/trunk@885 fefdeb5f-60dc-0310-8127-8f9354f1896f
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 360249ea..cb8e42f5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -31,6 +31,12 @@ AC_SUBST(PACKAGE_URL, [http://0pointer.de/lennart/projects/polypaudio/])
AC_SUBST(PA_API_VERSION, 8)
AC_SUBST(PA_PROTOCOL_VERSION, 8)
+AC_SUBST(LIBPOLYP_VERSION_INFO, [0:0:0])
+AC_SUBST(LIBPOLYPCORE_VERSION_INFO, [0:0:0])
+AC_SUBST(LIBPOLYP_SIMPLE_VERSION_INFO, [0:0:0])
+AC_SUBST(LIBPOLYP_BROWSE_VERSION_INFO, [0:0:0])
+AC_SUBST(LIBPOLYP_MAINLOOP_GLIB_VERSION_INFO, [0:0:0])
+
if type -p stow > /dev/null && test -d /usr/local/stow ; then
AC_MSG_NOTICE([*** Found /usr/local/stow: default install prefix set to /usr/local/stow/${PACKAGE_NAME}-${PACKAGE_VERSION} ***])
ac_default_prefix="/usr/local/stow/${PACKAGE_NAME}-${PACKAGE_VERSION}"
@@ -420,6 +426,13 @@ if test "x$PREOPEN_MODS" != "xall" ; then
AC_SUBST(PREOPEN_MODS)
fi
+AC_ARG_WITH(
+ [module-dir],
+ AC_HELP_STRING([--with-module-dir],[Directory where to install the modules to (defaults to ${libdir}/polypaudio-${PA_MAJORMINOR}]),
+ [modlibexecdir=$withval], [modlibexecdir="${libdir}/polypaudio-${PA_MAJORMINOR}"])
+
+AC_SUBST(modlibexecdir)
+
AC_ARG_ENABLE(
[force-preopen],
AC_HELP_STRING([--enable-force-preopen],[Preopen modules, even when dlopen() is supported.]),