summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2006-09-02 12:45:53 +0000
committerLennart Poettering <lennart@poettering.net>2006-09-02 12:45:53 +0000
commita00c3cb9afc3848fc3369b16a3187354176d3b99 (patch)
tree17a83f3ab220c1bfb26feaad6c86997a2f8bf89e /configure.ac
parent11b6c451b88099d2094183de5f4237ec578f4cfe (diff)
fix a few autoconf warnings (patch by Flameeyes)
git-svn-id: file:///home/lennart/svn/public/pulseaudio/trunk@1362 fefdeb5f-60dc-0310-8127-8f9354f1896f
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 10 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 7d85b32a..48b86cd3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -143,9 +143,18 @@ AC_HEADER_STDC
# POSIX
AC_CHECK_HEADERS([arpa/inet.h glob.h grp.h netdb.h netinet/in.h \
- netinet/in_systm.h netinet/ip.h netinet/tcp.h pwd.h sched.h \
+ netinet/in_systm.h netinet/tcp.h pwd.h sched.h \
sys/mman.h sys/resource.h sys/select.h sys/socket.h sys/wait.h \
syslog.h])
+AC_CHECK_HEADERS([netinet/ip.h], [], [],
+ [#include <sys/types.h>
+ #if HAVE_NETINET_IN_H
+ # include <netinet/in.h>
+ #endif
+ #if HAVE_NETINET_IN_SYSTM_H
+ # include <netinet/in_systm.h>
+ #endif
+ ])
AC_CHECK_HEADERS([regex.h], [HAVE_REGEX=1], [HAVE_REGEX=0])
AC_CHECK_HEADERS([sys/un.h], [HAVE_AF_UNIX=1], [HAVE_AF_UNIX=0])