summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorArnaud Fontaine <arnau@debian.org>2011-03-29 22:56:28 +0159
committerColin Guthrie <colin@mageia.org>2011-04-30 14:26:45 +0100
commitadb16f9ff42008c5b8f76133d8879fc15a82533f (patch)
treec400f5dc40bc8e6f74b0898a5c4bb0130f8f3c32 /configure.ac
parent2f7eb35f370bb79c12f229d109fc4dd2b74c9f47 (diff)
x11: More XCB fixes.
Commit 65ef80b fixed building with xcb-util >= 0.3.8, but the reply is never checked (possible SIGSEGV if the reply is NULL) nor freed (memory leak at each call of the functions). Also, remove include and dependencies on xcb-atom, as it was only meaningful for xcb_atom_get() and STRING, and depend instead on xcb >= 1.6 for XCB_ATOM_STRING.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 980d148d..76cf7e96 100644
--- a/configure.ac
+++ b/configure.ac
@@ -591,7 +591,7 @@ AC_ARG_ENABLE([x11],
[x11=auto])
if test "x${x11}" != xno ; then
- PKG_CHECK_MODULES(X11, [ x11-xcb ice sm xtst xcb-atom ],
+ PKG_CHECK_MODULES(X11, [ x11-xcb xcb >= 1.6 ice sm xtst ],
HAVE_X11=1,
[
HAVE_X11=0