summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMarc-André Lureau <marcandre.lureau@gmail.com>2009-01-07 16:33:43 +0200
committerMarc-André Lureau <marcandre.lureau@gmail.com>2009-01-08 11:52:02 +0200
commitdd9ca70759b8370db5df50ae8e84f86d01555106 (patch)
treedb4f1e5edfca4418cdc3572a62d5a7a456a644ce /configure.ac
parentc2450501af82d1c9d1994e4f4ce80d506d3c90ae (diff)
build: use pkg-config for X11
According to Daniel, AC_PATH_XTRA is sort-of deprecated. This patch changes the configure arguments, --x-includes=dir and --x-libraries=dir, which are now removed and use standard pkg-config. It also replaces --with{,out}-x with --{dis,en}able-x11, which is the same as other optionnal dependencies. (this patch was done in an attempt to solve a build issue on maemo, it turns out it didn't help)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac61
1 files changed, 40 insertions, 21 deletions
diff --git a/configure.ac b/configure.ac
index 82f92057..ae6dd964 100644
--- a/configure.ac
+++ b/configure.ac
@@ -411,21 +411,52 @@ AC_SUBST(pulselocaledir)
# External libraries #
###################################
+#### pkg-config ####
+
+# Check for pkg-config manually first, as if its not installed the
+# PKG_PROG_PKG_CONFIG macro won't be defined.
+AC_CHECK_PROG(have_pkg_config, pkg-config, yes, no)
+
+if test x"$have_pkg_config" = "xno"; then
+ AC_MSG_ERROR(pkg-config is required to install this program)
+fi
+
+PKG_PROG_PKG_CONFIG
+
#### X11 (optional) ####
-HAVE_X11=0
+AC_ARG_ENABLE([x11],
+ AS_HELP_STRING([--disable-x11],[Disable optional X11 support]),
+ [
+ case "${enableval}" in
+ yes) x11=yes ;;
+ no) x11=no ;;
+ *) AC_MSG_ERROR(bad value ${enableval} for --disable-x11) ;;
+ esac
+ ],
+ [x11=auto])
+
+if test "x${x11}" != xno ; then
+ PKG_CHECK_MODULES(X11, [ x11 ],
+ HAVE_X11=1,
+ [
+ HAVE_X11=0
+ if test "x$x11" = xyes ; then
+ AC_MSG_ERROR([*** X11 not found])
+ fi
+ ])
+else
+ HAVE_X11=0
+fi
-# The macro tests the host, not the build target
-if test "x$os_is_win32" != "x1" ; then
- AC_PATH_XTRA
- test "x$no_x" != "xyes" && HAVE_X11=1
+if test "x${HAVE_X11}" = x1 ; then
+ AC_DEFINE([HAVE_X11], 1, [Have X11?])
fi
+AC_SUBST(X11_CFLAGS)
+AC_SUBST(X11_LIBS)
AC_SUBST(HAVE_X11)
-AM_CONDITIONAL(HAVE_X11, test "x$HAVE_X11" = "x1")
-if test "x$HAVE_X11" = "x1" ; then
- AC_DEFINE([HAVE_X11], 1, [Have X11])
-fi
+AM_CONDITIONAL([HAVE_X11], [test "x$HAVE_X11" = x1])
#### Capabilities (optional) ####
@@ -450,18 +481,6 @@ fi
AC_CHECK_HEADERS([valgrind/memcheck.h])
-#### pkg-config ####
-
-# Check for pkg-config manually first, as if its not installed the
-# PKG_PROG_PKG_CONFIG macro won't be defined.
-AC_CHECK_PROG(have_pkg_config, pkg-config, yes, no)
-
-if test x"$have_pkg_config" = "xno"; then
- AC_MSG_ERROR(pkg-config is required to install this program)
-fi
-
-PKG_PROG_PKG_CONFIG
-
#### Sound file ####
PKG_CHECK_MODULES(LIBSNDFILE, [ sndfile >= 1.0.10 ])