summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorArun Raghavan <arun.raghavan@collabora.co.uk>2009-12-06 12:31:25 +0530
committerColin Guthrie <cguthrie@mandriva.org>2009-12-06 11:51:24 +0000
commite8a5746f2fcae59bfd18d39b621509b3ef130453 (patch)
treef94902497876669b4238798f160dae765a430c58 /configure.ac
parent978d33b609969c3b9bbbd759e0f11aaf856c80cf (diff)
Add a configure option to change 'udevrulesdir'
This patch serves two purposes: 1) Allows something other than the de-facto standard udev rules dir or /lib/udev/rules.d to be used (the udev build system allows you to customise this) 2) Allows a prefixed, non-root install (right now, the /lib/... path is hard-coded into the build system
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index dfbd9bc0..af60fff8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1395,6 +1395,13 @@ AC_ARG_WITH(
AC_SUBST(modlibexecdir)
+AC_ARG_WITH(
+ [udev-rules-dir],
+ AS_HELP_STRING([--with-udev-rules-dir],[Directory where to install udev rules to (defaults to /lib/udev/rules.d)]),
+ [udevrulesdir=$withval], [udevrulesdir="/lib/udev/rules.d"])
+
+AC_SUBST(udevrulesdir)
+
AC_ARG_ENABLE(
[force-preopen],
AS_HELP_STRING([--enable-force-preopen],[Preopen modules, even when dlopen() is supported.]),