summaryrefslogtreecommitdiffstats
path: root/doc/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2004-07-17 14:06:13 +0000
committerLennart Poettering <lennart@poettering.net>2004-07-17 14:06:13 +0000
commit7b8c329578d642d31618d487b97864306c43073c (patch)
tree4772f1ca82bfde919e559e0a85ce7d728ecb434c /doc/Makefile.am
parent3e379ca99d44c84b2117ac048ee6e84fc2837280 (diff)
add documentation
git-svn-id: file:///home/lennart/svn/public/pulseaudio/trunk@86 fefdeb5f-60dc-0310-8127-8f9354f1896f
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am39
1 files changed, 39 insertions, 0 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
new file mode 100644
index 00000000..015d503d
--- /dev/null
+++ b/doc/Makefile.am
@@ -0,0 +1,39 @@
+# $Id$
+
+# This file is part of polypaudio.
+#
+# polypaudio is free software; you can redistribute it and/or modify it
+# under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+#
+# polypaudio is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with polypaudio; if not, write to the Free Software Foundation,
+# Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA.
+
+noinst_DATA = README.html cli.html modules.html daemon.html README
+EXTRA_DIST = $(noinst_DATA) style.css README.html.in cli.html.in modules.html.in daemon.html.in
+
+MAINTAINERCLEANFILES = README README.html cli.html modules.html daemon.html
+CLEANFILES =
+
+if USE_LYNX
+README: README.html
+ lynx --dump $^ | sed 's,file://localhost/.*/doc/README.html,README,' > $@
+
+CLEANFILES += README
+endif
+
+tidy: README.html cli.html modules.html daemon.html
+ tidy -e < README.html
+ tidy -e < cli.html
+ tidy -e < modules.html
+ tidy -e < daemon.html
+
+.PHONY: tidy
+