summaryrefslogtreecommitdiffstats
path: root/polyp/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2004-11-17 00:05:25 +0000
committerLennart Poettering <lennart@poettering.net>2004-11-17 00:05:25 +0000
commit0a2bbc528b7865b08139155e0316738a717c4e42 (patch)
tree99166840892bb315fe109436093876386adac51d /polyp/Makefile.am
parentf5f6605254d17c5bc06b8c1ec98e8ee09009af10 (diff)
* some commenting work
* add new field "read_only" to memory blocks * add new API function pa_context_get_server() * filter capture data through mcalign on client * make module-tunnel use pa_socket_client_new_string() instead of using pa_resolve_server() directly. * remove pa_resolve_server() * remove debug.h and replace it by a macro definition on the gcc command line * some strbuf cleanups * small fixes in pa_stream for cleanup when server dies * new CLI command "load-sample-dir-lazy" * send FQDN as part of server info * rework mcalign, this time with memory block merging * fix iochannel cleanup when connection dies * check getaddrinfo() results git-svn-id: file:///home/lennart/svn/public/pulseaudio/trunk@286 fefdeb5f-60dc-0310-8127-8f9354f1896f
Diffstat (limited to 'polyp/Makefile.am')
-rw-r--r--polyp/Makefile.am17
1 files changed, 13 insertions, 4 deletions
diff --git a/polyp/Makefile.am b/polyp/Makefile.am
index 9ea6932a..506cdc34 100644
--- a/polyp/Makefile.am
+++ b/polyp/Makefile.am
@@ -27,6 +27,9 @@ AM_CFLAGS+=-DDLSEARCHPATH=\"$(modlibdir)\"
AM_CFLAGS+=-DDEFAULT_CONFIG_DIR=\"$(polypconfdir)\"
AM_CFLAGS+=-DPOLYPAUDIO_BINARY=\"$(bindir)/polypaudio\"
+# This cool debug trap works on i386/gcc only
+AM_CFLAGS+='-DDEBUG_TRAP=__asm__("int $$3")'
+
AM_LIBADD=$(PTHREAD_LIBS) -lm
AM_LDADD=$(PTHREAD_LIBS) -lm
@@ -40,7 +43,8 @@ noinst_PROGRAMS = \
cpulimit-test \
cpulimit-test2 \
voltest \
- strlist-test
+ strlist-test \
+ mcalign-test
polypconf_DATA=default.pa daemon.conf client.conf
@@ -196,7 +200,6 @@ polypaudio_SOURCES = idxset.c idxset.h \
autoload.c autoload.h \
xmalloc.c xmalloc.h \
subscribe.h subscribe.c \
- debug.h \
sound-file-stream.c sound-file-stream.h \
cpulimit.c cpulimit.h \
log.c log.h \
@@ -206,7 +209,8 @@ polypaudio_SOURCES = idxset.c idxset.h \
dumpmodules.c dumpmodules.h \
conf-parser.h conf-parser.c \
caps.h caps.c \
- props.h props.c
+ props.h props.c \
+ mcalign.c mcalign.h
polypaudio_CFLAGS = $(AM_CFLAGS) $(LIBSAMPLERATE_CFLAGS) $(LIBSNDFILE_CFLAGS)
polypaudio_INCLUDES = $(INCLTDL)
@@ -441,7 +445,8 @@ libpolyp_@PA_MAJORMINOR@_la_SOURCES = polyplib.h \
client-conf.c client-conf.h \
conf-parser.c conf-parser.h \
strlist.c strlist.h \
- strbuf.c strbuf.h
+ strbuf.c strbuf.h \
+ mcalign.c mcalign.h
libpolyp_@PA_MAJORMINOR@_la_CFLAGS = $(AM_CFLAGS)
libpolyp_@PA_MAJORMINOR@_la_LDFLAGS = -version-info 0:0:0
@@ -495,6 +500,10 @@ strlist_test_SOURCES = strlist-test.c strlist.c strlist.h strbuf.c strbuf.h util
strlist_test_CFLAGS = $(AM_CFLAGS)
strlist_test_LDADD = $(AM_LDADD)
+mcalign_test_SOURCES = mcalign-test.c util.c util.h xmalloc.c xmalloc.h log.c log.h mcalign.c mcalign.h memchunk.c memchunk.h memblock.c memblock.h
+mcalign_test_CFLAGS = $(AM_CFLAGS)
+mcalign_test_LDADD = $(AM_LDADD)
+
cpulimit_test_SOURCES = cpulimit-test.c cpulimit.c util.c log.c cpulimit.h util.h log.h
cpulimit_test_CFLAGS = $(AM_CFLAGS)
cpulimit_test_LDADD = $(AM_LDADD) libpolyp-mainloop-@PA_MAJORMINOR@.la