summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorPierre Ossman <ossman@cendio.se>2006-04-18 13:36:59 +0000
committerPierre Ossman <ossman@cendio.se>2006-04-18 13:36:59 +0000
commit2d6ab01fbb9c670b5b1831aea0681fd17fcdcf88 (patch)
tree3f2863953fa91d52ddf104d6d5cc32801bd63405 /src/Makefile.am
parentc3087d02ba272059f86f9b1794f792daf2cd8e89 (diff)
We need to emulate sendmsg/recvmsg to support rtp on Windows. Will do
this some time in the future. git-svn-id: file:///home/lennart/svn/public/pulseaudio/trunk@740 fefdeb5f-60dc-0310-8127-8f9354f1896f
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am14
1 files changed, 12 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index c5864373..f6fc509b 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -589,8 +589,13 @@ modlib_LTLIBRARIES = \
libprotocol-simple.la \
libprotocol-esound.la \
libprotocol-native.la \
- libprotocol-http.la \
+ libprotocol-http.la
+
+# We need to emulate sendmsg/recvmsg to support this on Win32
+if !OS_IS_WIN32
+modlib_LTLIBRARIES += \
librtp.la
+endif
if HAVE_X11
polypcoreinclude_HEADERS += \
@@ -721,9 +726,14 @@ modlib_LTLIBRARIES += \
module-null-sink.la \
module-esound-sink.la \
module-http-protocol-tcp.la \
- module-detect.la \
+ module-detect.la
+
+# See comment at librtp.la above
+if !OS_IS_WIN32
+modlib_LTLIBRARIES += \
module-rtp-send.la \
module-rtp-recv.la
+endif
if HAVE_AF_UNIX
modlib_LTLIBRARIES += \