summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2004-06-11 00:33:43 +0000
committerLennart Poettering <lennart@poettering.net>2004-06-11 00:33:43 +0000
commit9e3ad2380a28a7473a1dfa9ae41697ebacfd85cc (patch)
tree574c177004f4acec6f10ac6460e803e2e7a60b0a /src/Makefile.am
parenta5daff7859c3a8904cb379c59f3cefbaae4f57f2 (diff)
autoconf
git-svn-id: file:///home/lennart/svn/public/pulseaudio/trunk@5 fefdeb5f-60dc-0310-8127-8f9354f1896f
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am55
1 files changed, 55 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 00000000..c64babb3
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,55 @@
+# $Id: Makefile.am 27 2003-10-22 22:34:06Z lennart $
+#
+# This file is part of polypaudio.
+#
+# polypaudio is free software; you can redistribute it and/or modify it
+# under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+#
+# polypaudio is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with polypaudio; if not, write to the Free Software Foundation,
+# Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA.
+
+AM_CFLAGS=-ansi -D_GNU_SOURCE
+
+bin_PROGRAMS = polypaudio
+
+pkglib_LTLIBRARIES=protocol-simple.la protocol-simple-tcp.la \
+ socket-server.la sink-pipe.la pstream.la iochannel.la packet.la
+
+polypaudio_SOURCES = idxset.c queue.c strbuf.c mainloop.c \
+ memblock.c sample.c memblockq.c client.c \
+ core.c main.c outputstream.c inputstream.c source.c sink.c \
+ module.c
+polypaudio_INCLUDES = $(INCLTDL)
+polypaudio_LDADD = $(LIBLTDL)
+polypaudio_LDFLAGS=-export-dynamic
+
+protocol_simple_la_SOURCES = protocol-simple.c
+protocol_simple_la_LDFLAGS = -module -avoid-version
+
+protocol_simple_tcp_la_SOURCES = protocol-simple-tcp.c
+protocol_simple_tcp_la_LDFLAGS = -module -avoid-version
+protocol_simple_tcp_la_LIBADD = protocol-simple.la socket-server.la
+
+socket_server_la_SOURCES = socket-server.c
+socket_server_la_LDFLAGS = -module -avoid-version
+
+sink_pipe_la_SOURCES = sink-pipe.c
+sink_pipe_la_LDFLAGS = -module -avoid-version
+
+pstream_la_SOURCES = pstream.c
+pstream_la_LDFLAGS = -module -avoid-version
+
+iochannel_la_SOURCES = pstream.c
+iochannel_la_LDFLAGS = -module -avoid-version
+
+packet_la_SOURCES = pstream.c
+packet_la_LDFLAGS = -module -avoid-version
+