summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2006-08-18 19:56:51 +0000
committerLennart Poettering <lennart@poettering.net>2006-08-18 19:56:51 +0000
commit35caf0c4eaedbf8553c1fe59e7d3e3438e59a7d9 (patch)
tree37b789bae59578f94b66549a2b5e6c476db3daf0 /src/Makefile.am
parentc3fc2eaa7e44c1d71f53e4f61c874f551a65de3e (diff)
add new test memblock-test for testing SHM import/export
git-svn-id: file:///home/lennart/svn/public/pulseaudio/trunk@1268 fefdeb5f-60dc-0310-8127-8f9354f1896f
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am17
1 files changed, 13 insertions, 4 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 0ab0436b..c4988d8e 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -197,7 +197,8 @@ noinst_PROGRAMS = \
utf8-test \
get-binary-name-test \
ipacl-test \
- hook-list-test
+ hook-list-test \
+ memblock-test
if HAVE_SIGXCPU
noinst_PROGRAMS += \
@@ -242,6 +243,11 @@ hook_list_test_CFLAGS = $(AM_CFLAGS)
hook_list_test_LDADD = $(AM_LDADD) libpulsecore.la
hook_list_test_LDFLAGS = $(AM_LDFLAGS) $(BINLDFLAGS)
+memblock_test_SOURCES = tests/memblock-test.c
+memblock_test_CFLAGS = $(AM_CFLAGS)
+memblock_test_LDADD = $(AM_LDADD) libpulsecore.la
+memblock_test_LDFLAGS = $(AM_LDFLAGS) $(BINLDFLAGS)
+
mcalign_test_SOURCES = tests/mcalign-test.c
mcalign_test_CFLAGS = $(AM_CFLAGS)
mcalign_test_LDADD = $(AM_LDADD) $(WINSOCK_LIBS) libpulsecore.la
@@ -414,7 +420,8 @@ libpulse_la_SOURCES += \
pulsecore/strlist.c pulsecore/strlist.h \
pulsecore/tagstruct.c pulsecore/tagstruct.h \
pulsecore/core-error.c pulsecore/core-error.h \
- pulsecore/winsock.h pulsecore/creds.h
+ pulsecore/winsock.h pulsecore/creds.h \
+ pulsecore/shm.c pulsecore/shm.h
if OS_IS_WIN32
libpulse_la_SOURCES += \
@@ -519,7 +526,8 @@ pulsecoreinclude_HEADERS = \
pulsecore/source-output.h \
pulsecore/strbuf.h \
pulsecore/tokenizer.h \
- pulsecore/creds.h
+ pulsecore/creds.h \
+ pulsecore/shm.h
lib_LTLIBRARIES += libpulsecore.la
@@ -586,7 +594,8 @@ libpulsecore_la_SOURCES += \
pulsecore/tokenizer.c pulsecore/tokenizer.h \
pulsecore/winsock.h \
pulsecore/core-error.c pulsecore/core-error.h \
- pulsecore/hook-list.c pulsecore/hook-list.h
+ pulsecore/hook-list.c pulsecore/hook-list.h \
+ pulsecore/shm.c pulsecore/shm.h
if OS_IS_WIN32
libpulsecore_la_SOURCES += \