summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorPierre Ossman <ossman@cendio.se>2006-09-11 07:56:03 +0000
committerPierre Ossman <ossman@cendio.se>2006-09-11 07:56:03 +0000
commit772645922a450f5d366bd6e077a44582e7a7b79f (patch)
treefc1732ad34e56786eea53735c2aa471e2e304ad7 /src/Makefile.am
parenta85b3e2dd49adc5addab25e5ceeb8eb56e283e48 (diff)
Fix up build structure for platform dependent modules. Also add implementation
on Win32 for pa_once(). git-svn-id: file:///home/lennart/svn/public/pulseaudio/trunk@1395 fefdeb5f-60dc-0310-8127-8f9354f1896f
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am50
1 files changed, 23 insertions, 27 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 7db0f8c7..c04507dc 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -70,6 +70,18 @@ AM_LDFLAGS+=-Wl,--export-all-symbols
WINSOCK_LIBS=-lwsock32 -lws2_32 -lwininet
endif
+if OS_IS_WIN32
+PA_THREAD_OBJS = \
+ pulsecore/once-win32.c pulsecore/once.h \
+ pulsecore/mutex-win32.c pulsecore/mutex.h \
+ pulsecore/thread-win32.c pulsecore/thread.h
+else
+PA_THREAD_OBJS = \
+ pulsecore/once-posix.c pulsecore/once.h \
+ pulsecore/mutex-posix.c pulsecore/mutex.h \
+ pulsecore/thread-posix.c pulsecore/thread.h
+endif
+
###################################
# Extra files #
###################################
@@ -251,14 +263,15 @@ memblock_test_CFLAGS = $(AM_CFLAGS)
memblock_test_LDADD = $(AM_LDADD) libpulsecore.la
memblock_test_LDFLAGS = $(AM_LDFLAGS) $(BINLDFLAGS)
-thread_test_SOURCES = tests/thread-test.c pulse/xmalloc.c pulsecore/flist.c pulsecore/thread-posix.c pulsecore/mutex-posix.c pulsecore/log.c pulsecore/core-util.c pulse/util.c pulse/utf8.c pulsecore/core-error.c pulsecore/once-posix.c
+thread_test_SOURCES = tests/thread-test.c
thread_test_CFLAGS = $(AM_CFLAGS)
-thread_test_LDADD = $(AM_LDADD)
+thread_test_LDADD = $(AM_LDADD) libpulsecore.la
thread_test_LDFLAGS = $(AM_LDFLAGS) $(BINLDFLAGS)
-flist_test_SOURCES = tests/flist-test.c pulse/xmalloc.c pulsecore/flist.c pulsecore/thread-posix.c pulsecore/mutex-posix.c pulsecore/log.c pulsecore/core-util.c pulse/util.c pulse/utf8.c pulsecore/core-error.c pulsecore/once-posix.c
+flist_test_SOURCES = tests/flist-test.c \
+ pulsecore/flist.c pulsecore/flist.h
flist_test_CFLAGS = $(AM_CFLAGS)
-flist_test_LDADD = $(AM_LDADD)
+flist_test_LDADD = $(AM_LDADD) libpulsecore.la
flist_test_LDFLAGS = $(AM_LDFLAGS) $(BINLDFLAGS)
mcalign_test_SOURCES = tests/mcalign-test.c
@@ -434,7 +447,8 @@ libpulse_la_SOURCES += \
pulsecore/tagstruct.c pulsecore/tagstruct.h \
pulsecore/core-error.c pulsecore/core-error.h \
pulsecore/winsock.h pulsecore/creds.h \
- pulsecore/shm.c pulsecore/shm.h
+ pulsecore/shm.c pulsecore/shm.h \
+ $(PA_THREAD_OBJS)
if OS_IS_WIN32
libpulse_la_SOURCES += \
@@ -544,7 +558,8 @@ pulsecoreinclude_HEADERS = \
pulsecore/llist.h \
pulsecore/refcnt.h \
pulsecore/mutex.h \
- pulsecore/thread.h
+ pulsecore/thread.h \
+ pulsecore/once.h
lib_LTLIBRARIES += libpulsecore.la
@@ -586,7 +601,6 @@ libpulsecore_la_SOURCES += \
pulsecore/modargs.c pulsecore/modargs.h \
pulsecore/modinfo.c pulsecore/modinfo.h \
pulsecore/module.c pulsecore/module.h \
- pulsecore/mutex.h \
pulsecore/namereg.c pulsecore/namereg.h \
pulsecore/pid.c pulsecore/pid.h \
pulsecore/pipe.c pulsecore/pipe.h \
@@ -609,36 +623,18 @@ libpulsecore_la_SOURCES += \
pulsecore/source.c pulsecore/source.h \
pulsecore/source-output.c pulsecore/source-output.h \
pulsecore/strbuf.c pulsecore/strbuf.h \
- pulsecore/thread.h \
pulsecore/tokenizer.c pulsecore/tokenizer.h \
pulsecore/winsock.h \
pulsecore/core-error.c pulsecore/core-error.h \
pulsecore/hook-list.c pulsecore/hook-list.h \
- pulsecore/shm.c pulsecore/shm.h
+ pulsecore/shm.c pulsecore/shm.h \
+ $(PA_THREAD_OBJS)
if OS_IS_WIN32
libpulsecore_la_SOURCES += \
pulsecore/dllmain.c
endif
-if OS_IS_WIN32
-libpulsecore_la_SOURCES += \
- pulsecore/mutex-win32.c \
- pulsecore/thread-win32.c
-libpulse_la_SOURCES += \
- pulsecore/mutex-win32.c \
- pulsecore/thread-win32.c
-else
-libpulsecore_la_SOURCES += \
- pulsecore/mutex-posix.c \
- pulsecore/thread-posix.c \
- pulsecore/once-posix.c
-libpulse_la_SOURCES += \
- pulsecore/mutex-posix.c \
- pulsecore/thread-posix.c \
- pulsecore/once-posix.c
-endif
-
libpulsecore_la_CPPFLAGS = $(AM_CPPFLAGS) $(LIBOIL_CFLAGS)
libpulsecore_la_LDFLAGS = -version-info $(LIBPULSECORE_VERSION_INFO)
libpulsecore_la_LIBADD = $(AM_LIBADD) $(LIBLTDL) $(LIBSAMPLERATE_LIBS) $(LIBSNDFILE_LIBS) $(WINSOCK_LIBS) $(LIBOIL_LIBS) $(LIBICONV)