summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2006-07-14 00:19:09 +0000
committerLennart Poettering <lennart@poettering.net>2006-07-14 00:19:09 +0000
commit883ce83f92c408c77bf1a50952893ee5af3f0acc (patch)
tree200aad63a7a695adcae49e63fb7da805c56f13fb /src/Makefile.am
parenta87c43d61e950b60b44e7e786116dd1e2fad4dc6 (diff)
add new test get-binary-name-test for testing pa_get_binary_name()
git-svn-id: file:///home/lennart/svn/public/pulseaudio/trunk@1079 fefdeb5f-60dc-0310-8127-8f9354f1896f
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index fad01e08..0db8a8f2 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -192,7 +192,8 @@ noinst_PROGRAMS = \
interpol-test \
channelmap-test \
thread-mainloop-test \
- utf8-test
+ utf8-test \
+ get-binary-name-test
if HAVE_SIGXCPU
noinst_PROGRAMS += \
@@ -225,6 +226,11 @@ utf8_test_CFLAGS = $(AM_CFLAGS)
utf8_test_LDADD = $(AM_LDADD) libpulsecore.la
utf8_test_LDFLAGS = $(AM_LDFLAGS) $(BINLDFLAGS)
+get_binary_name_test_SOURCES = tests/get-binary-name-test.c
+get_binary_name_test_CFLAGS = $(AM_CFLAGS)
+get_binary_name_test_LDADD = $(AM_LDADD) libpulse.la
+get_binary_name_test_LDFLAGS = $(AM_LDFLAGS) $(BINLDFLAGS)
+
mcalign_test_SOURCES = tests/mcalign-test.c
mcalign_test_CFLAGS = $(AM_CFLAGS)
mcalign_test_LDADD = $(AM_LDADD) $(WINSOCK_LIBS) libpulsecore.la