summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorColin Guthrie <pulse@colin.guthr.ie>2008-06-03 19:55:01 +0000
committerColin Guthrie <pulse@colin.guthr.ie>2008-06-03 19:55:01 +0000
commit3166ce86d0cd7f3ee02cdbb1a3a09e0b5e91d5f8 (patch)
tree60e04e178cd1468f34d0ba8e61970f4e789d3dfb /src/Makefile.am
parent78ae61217dbd5a3ad097917c7335a2b914734bcd (diff)
Also link libpulsecore.la to some libraries (needed for logging). Discovered while compiling with --as-needed
git-svn-id: file:///home/lennart/svn/public/pulseaudio/trunk@2495 fefdeb5f-60dc-0310-8127-8f9354f1896f
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index cf5fa04e..6dbd364c 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -640,7 +640,7 @@ endif
libpulsedsp_la_SOURCES = utils/padsp.c
libpulsedsp_la_CFLAGS = $(AM_CFLAGS)
-libpulsedsp_la_LIBADD = $(AM_LIBADD) libpulse.la
+libpulsedsp_la_LIBADD = $(AM_LIBADD) libpulse.la libpulsecore.la
libpulsedsp_la_LDFLAGS = -avoid-version
###################################
@@ -924,7 +924,7 @@ libpstream_la_LIBADD = $(AM_LIBADD) libpulsecore.la libpacket.la libiochannel.la
libpstream_util_la_SOURCES = pulsecore/pstream-util.c pulsecore/pstream-util.h
libpstream_util_la_LDFLAGS = -avoid-version
-libpstream_util_la_LIBADD = $(AM_LIBADD) libpacket.la libpstream.la libtagstruct.la
+libpstream_util_la_LIBADD = $(AM_LIBADD) libpacket.la libpstream.la libtagstruct.la libpulsecore.la
libpdispatch_la_SOURCES = pulsecore/pdispatch.c pulsecore/pdispatch.h
libpdispatch_la_LDFLAGS = -avoid-version