summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2007-11-11 23:18:19 +0000
committerLennart Poettering <lennart@poettering.net>2007-11-11 23:18:19 +0000
commit5054f3623ff82ab0c263e15c47779b0caa841b29 (patch)
tree08b9db24040d969fd5da278e44bc2bd80d7ce366 /src/Makefile.am
parente8092bede9c2c9daac6c6035ca7a130b2c9a7e5b (diff)
add new fun module that automatically mutes your audio devices when you leave with your bluetooth phone, and unmutes when you come back
git-svn-id: file:///home/lennart/svn/public/pulseaudio/trunk@2048 fefdeb5f-60dc-0310-8127-8f9354f1896f
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am26
1 files changed, 25 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 1a24a529..36d27ef4 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -736,6 +736,7 @@ libpulsecore_la_SOURCES += \
pulsecore/macro.h \
pulsecore/once.c pulsecore/once.h \
pulsecore/time-smoother.c pulsecore/time-smoother.h \
+ pulsecore/start-child.c pulsecore/start-child.h \
$(PA_THREAD_OBJS)
if OS_IS_WIN32
@@ -1052,11 +1053,13 @@ modlibexec_LTLIBRARIES += \
module-jack-source.la
endif
+pulselibexec_PROGRAMS =
+
if HAVE_GCONF
modlibexec_LTLIBRARIES += \
module-gconf.la
-pulselibexec_PROGRAMS = \
+pulselibexec_PROGRAMS += \
gconf-helper
endif
@@ -1071,6 +1074,14 @@ modlibexec_LTLIBRARIES += \
module-hal-detect.la
endif
+if HAVE_BLUEZ
+modlibexec_LTLIBRARIES += \
+ module-bt-proximity.la
+
+pulselibexec_PROGRAMS += \
+ bt-proximity-helper
+endif
+
# These are generated by a M4 script
SYMDEF_FILES = \
@@ -1121,6 +1132,7 @@ SYMDEF_FILES = \
modules/module-rescue-streams-symdef.h \
modules/module-suspend-on-idle-symdef.h \
modules/module-hal-detect-symdef.h \
+ modules/module-bt-proximity-symdef.h \
modules/gconf/module-gconf-symdef.h
EXTRA_DIST += $(SYMDEF_FILES)
@@ -1419,6 +1431,17 @@ gconf_helper_LDADD = $(AM_LDADD) $(GCONF_LIBS) libpulsecore.la
gconf_helper_CFLAGS = $(AM_CFLAGS) $(GCONF_CFLAGS)
gconf_helper_LDFLAGS = $(AM_LDFLAGS) $(BINLDFLAGS)
+# Bluetooth proximity
+module_bt_proximity_la_SOURCES = modules/module-bt-proximity.c
+module_bt_proximity_la_LDFLAGS = -module -avoid-version
+module_bt_proximity_la_LIBADD = $(AM_LIBADD) $(DBUS_LIBS) libpulsecore.la libdbus-util.la
+module_bt_proximity_la_CFLAGS = $(AM_CFLAGS) $(DBUS_CFLAGS) -DPA_BT_PROXIMITY_HELPER=\"$(pulselibexecdir)/bt-proximity-helper\"
+
+bt_proximity_helper_SOURCES = modules/bt-proximity-helper.c
+bt_proximity_helper_LDADD = $(AM_LDADD) $(BLUEZ_LIBS)
+bt_proximity_helper_CFLAGS = $(AM_CFLAGS) $(BLUEZ_CFLAGS)
+bt_proximity_helper_LDFLAGS = $(AM_LDFLAGS) $(BINLDFLAGS)
+
###################################
# Some minor stuff #
###################################
@@ -1455,6 +1478,7 @@ daemon.conf: daemon/daemon.conf.in Makefile
install-exec-hook:
chown root $(DESTDIR)$(bindir)/pulseaudio ; true
chmod u+s $(DESTDIR)$(bindir)/pulseaudio
+ chmod u+s $(DESTDIR)$(pulselibexecdir)/bt-proximity-helper
ln -sf pacat $(DESTDIR)$(bindir)/parec
rm -f $(DESTDIR)$(modlibexecdir)/*.a
rm -f $(DESTDIR)$(libdir)/libpulsedsp.a