summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2007-12-23 20:12:37 +0000
committerLennart Poettering <lennart@poettering.net>2007-12-23 20:12:37 +0000
commit63c616eeccdea593a1c8dc65405e02c2a71038fe (patch)
tree862587b89d1aa76698812788cd2fe88ad7e5e7fe /src/Makefile.am
parent8ed2a8c042f22131762dff91008cbe96d8337ae1 (diff)
add new property list implementation
git-svn-id: file:///home/lennart/svn/public/pulseaudio/trunk@2085 fefdeb5f-60dc-0310-8127-8f9354f1896f
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am14
1 files changed, 11 insertions, 3 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 44f906f0..8a0ded83 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -254,7 +254,8 @@ noinst_PROGRAMS = \
smoother-test \
mix-test \
remix-test \
- envelope-test
+ envelope-test \
+ proplist-test
if HAVE_SIGXCPU
noinst_PROGRAMS += \
@@ -424,6 +425,11 @@ envelope_test_LDADD = $(AM_LDADD) libpulsecore.la
envelope_test_CFLAGS = $(AM_CFLAGS) $(LIBOIL_CFLAGS)
envelope_test_LDFLAGS = $(AM_LDFLAGS) $(BINLDFLAGS) $(LIBOIL_LIBS)
+proplist_test_SOURCES = tests/proplist-test.c
+proplist_test_LDADD = $(AM_LDADD) libpulse.la
+proplist_test_CFLAGS = $(AM_CFLAGS) $(LIBOIL_CFLAGS)
+proplist_test_LDFLAGS = $(AM_LDFLAGS) $(BINLDFLAGS) $(LIBOIL_LIBS)
+
###################################
# Client library #
###################################
@@ -451,7 +457,8 @@ pulseinclude_HEADERS = \
pulse/util.h \
pulse/version.h \
pulse/volume.h \
- pulse/xmalloc.h
+ pulse/xmalloc.h \
+ pulse/proplist.h
if HAVE_AVAHI
pulseinclude_HEADERS += \
@@ -501,7 +508,8 @@ libpulse_la_SOURCES = \
pulse/utf8.c pulse/utf8.h \
pulse/util.c pulse/util.h \
pulse/volume.c pulse/volume.h \
- pulse/xmalloc.c pulse/xmalloc.h
+ pulse/xmalloc.c pulse/xmalloc.h \
+ pulse/proplist.c pulse/proplist.h
# Internal stuff that is shared with libpulsecore
libpulse_la_SOURCES += \