summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2007-11-09 17:11:45 +0000
committerLennart Poettering <lennart@poettering.net>2007-11-09 17:11:45 +0000
commitb0a68fd09ff6fa62accdc29307c5f445cc054a94 (patch)
tree9d7383e7b08d35d77382f183591d03895bd6f827 /src/Makefile.am
parentc1985c2acc43f5d2c23e1e736588c5ef3a398a17 (diff)
optimize mixing code a bit. Add mixers for S32LE, S32BE, ULAW, ALAW and FLOAT32BE. Add volume adjusters for FLOAT32BE, ALAW, ULAW.
git-svn-id: file:///home/lennart/svn/public/pulseaudio/trunk@2041 fefdeb5f-60dc-0310-8127-8f9354f1896f
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 024988ba..8fe7be9d 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -239,7 +239,8 @@ noinst_PROGRAMS = \
rtpoll-test \
sig2str-test \
resampler-test \
- smoother-test
+ smoother-test \
+ mix-test
if HAVE_SIGXCPU
noinst_PROGRAMS += \
@@ -389,6 +390,11 @@ resampler_test_LDADD = $(AM_LDADD) libpulsecore.la
resampler_test_CFLAGS = $(AM_CFLAGS) $(LIBOIL_CFLAGS)
resampler_test_LDFLAGS = $(AM_LDFLAGS) $(BINLDFLAGS) $(LIBOIL_LIBS)
+mix_test_SOURCES = tests/mix-test.c
+mix_test_LDADD = $(AM_LDADD) libpulsecore.la
+mix_test_CFLAGS = $(AM_CFLAGS) $(LIBOIL_CFLAGS)
+mix_test_LDFLAGS = $(AM_LDFLAGS) $(BINLDFLAGS) $(LIBOIL_LIBS)
+
smoother_test_SOURCES = tests/smoother-test.c
smoother_test_LDADD = $(AM_LDADD) libpulsecore.la
smoother_test_CFLAGS = $(AM_CFLAGS)