summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorDiego E. 'Flameeyes' Pettenò <flameeyes@gmail.com>2009-01-20 00:55:39 +0100
committerDiego E. 'Flameeyes' Pettenò <flameeyes@gmail.com>2009-01-20 00:55:39 +0100
commitbd70e8053165bdee620356cdff02c3979d7138e7 (patch)
treed41200443166d7a5a9bc39ddfee0e93527a01aae /src/Makefile.am
parent8c4e2be05b519c54cb51c161b7cd08bf9e46ab2b (diff)
Allow to opt-out from building tests.
Since the tests are only useful either if you're hacking at pulseaudio as a developer, or when running "make check", allow users to opt-out from their build. This for instance allows for Gentoo users not to build the tests when installing the ebuild with tests disabled, and also allow for skipping over eventually broken tests when trying to get the basic build going on a port.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am12
1 files changed, 9 insertions, 3 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index e8f0a820..fbe9e914 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -253,7 +253,7 @@ TESTS = \
lock-autospawn-test \
prioq-test
-noinst_PROGRAMS = \
+TESTS_BINARIES = \
mainloop-test \
mcalign-test \
pacat-simple \
@@ -293,7 +293,7 @@ if HAVE_SIGXCPU
#TESTS += \
# cpulimit-test \
# cpulimit-test2
-noinst_PROGRAMS += \
+TESTS_BINARIES += \
cpulimit-test \
cpulimit-test2
endif
@@ -301,10 +301,16 @@ endif
if HAVE_GLIB20
TESTS += \
mainloop-test-glib
-noinst_PROGRAMS += \
+TESTS_BINARIES += \
mainloop-test-glib
endif
+if BUILD_TESTS_DEFAULT
+noinst_PROGRAMS = $(TESTS_BINARIES)
+else
+check_PROGRAMS = $(TESTS_BINARIES)
+endif
+
mainloop_test_SOURCES = tests/mainloop-test.c
mainloop_test_CFLAGS = $(AM_CFLAGS)
mainloop_test_LDADD = $(AM_LDADD) libpulse.la