summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2009-02-20 03:19:33 +0100
committerLennart Poettering <lennart@poettering.net>2009-02-20 03:19:33 +0100
commitfa2e07a0bd4d02280c397099b612ce4d56673c10 (patch)
treeba9aebc900a09e80856b3c2b37ec2f82dd187103 /src/Makefile.am
parent9f813dd5b306e59b40c5c88c52406638a8062749 (diff)
add test tool for debugging broken timing in sound drivers
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am14
1 files changed, 12 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index f385c0ab..ceafdf79 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -313,6 +313,11 @@ TESTS_BINARIES += \
gtk-test
endif
+if HAVE_ALSA
+TESTS_BINARIES += \
+ alsa-time-test
+endif
+
if BUILD_TESTS_DEFAULT
noinst_PROGRAMS = $(TESTS_BINARIES)
else
@@ -514,6 +519,11 @@ gtk_test_LDADD = $(AM_LDADD) libpulse.la libpulse-mainloop-glib.la
gtk_test_CFLAGS = $(AM_CFLAGS) $(GTK20_CFLAGS)
gtk_test_LDFLAGS = $(AM_LDFLAGS) $(BINLDFLAGS) $(GTK20_LIBS)
+alsa_time_test_SOURCES = tests/alsa-time-test.c
+alsa_time_test_LDADD = $(AM_LDADD)
+alsa_time_test_CFLAGS = $(AM_CFLAGS) $(ASOUNDLIB_CFLAGS)
+alsa_time_test_LDFLAGS = $(AM_LDFLAGS) $(BINLDFLAGS) $(ASOUNDLIB_LIBS)
+
###################################
# Common library #
###################################
@@ -960,6 +970,8 @@ modlibexec_LTLIBRARIES += \
module-oss.la
endif
+pulselibexec_PROGRAMS =
+
if HAVE_ALSA
modlibexec_LTLIBRARIES += \
libalsa-util.la \
@@ -995,8 +1007,6 @@ modlibexec_LTLIBRARIES += \
module-jack-source.la
endif
-pulselibexec_PROGRAMS =
-
if HAVE_GCONF
modlibexec_LTLIBRARIES += \
module-gconf.la