summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorDiego E. 'Flameeyes' Pettenò <flameeyes@gmail.com>2009-01-19 17:20:18 +0100
committerDiego E. 'Flameeyes' Pettenò <flameeyes@gmail.com>2009-01-19 17:20:18 +0100
commit348c2cab712203f23310b56952d9b42284af8482 (patch)
tree774d4cd7c5b54a0087abd9c073a3b7a822b8fc6b /src/Makefile.am
parent5793f93350dd8f29b7bc97eb1ad38873e4ecebde (diff)
Create only the directory the current target should be created into.
With this change, instead of running multiple `mkdir -p` commands in all the rules for all the generated definition files, only the call for the current generated file is executed. Not only it should shorten build time (especially for parallel make) but it also fixes out-of-tree builds when new directories are added. The $(dir $@) construct is GNU make-specific, but the rest of the buildsystem is already GNU make-dependent so there should be no problem.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am5
1 files changed, 1 insertions, 4 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 99ed7b2b..e6feddd3 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1068,10 +1068,7 @@ EXTRA_DIST += $(SYMDEF_FILES)
BUILT_SOURCES += $(SYMDEF_FILES)
$(SYMDEF_FILES): modules/module-defs.h.m4
- $(MKDIR_P) modules
- $(MKDIR_P) modules/gconf
- $(MKDIR_P) modules/rtp
- $(MKDIR_P) modules/bluetooth
+ $(MKDIR_P) $(dir $@)
$(M4) -Dfname="$@" $< > $@
# Flat volume