summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorDiego E. 'Flameeyes' Pettenò <flameeyes@gmail.com>2009-01-19 17:30:41 +0100
committerDiego E. 'Flameeyes' Pettenò <flameeyes@gmail.com>2009-01-19 17:30:41 +0100
commit7104d54bbce8f9bd2553e16f45f3a0f69ac75b8b (patch)
treed3b44d866868c3a32ba45a6a0fc8272b74ab2083 /src/Makefile.am
parent348c2cab712203f23310b56952d9b42284af8482 (diff)
Add proper -I directives for out-of-tree builds.
When building out of tree, the generated files are put in builddir rather than srcdir, so handle that properly.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index e6feddd3..9dd44657 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -47,10 +47,15 @@ endif
AM_CFLAGS = \
-I$(top_srcdir)/src \
+ -I$(top_builddir)/src \
-I$(top_srcdir)/src/modules \
+ -I$(top_builddir)/src/modules \
-I$(top_srcdir)/src/modules/rtp \
+ -I$(top_builddir)/src/modules/rtp \
-I$(top_srcdir)/src/modules/gconf \
+ -I$(top_builddir)/src/modules/gconf \
-I$(top_srcdir)/src/modules/bluetooth \
+ -I$(top_builddir)/src/modules/bluetooth \
-I$(top_srcdir)/src/modules/raop \
$(PTHREAD_CFLAGS) -D_POSIX_PTHREAD_SEMANTICS \
$(LTDLINCL) \