summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorJuho Hämäläinen <juho.hamalainen@digia.com>2009-08-12 18:30:14 +0300
committerLennart Poettering <lennart@poettering.net>2009-08-15 02:07:00 +0200
commitea5cdcbe52e3e1ac6189fb6472fafe61fbfdd73c (patch)
treef4874302499ffe8d66907cf6304dca0cd7386960 /src/Makefile.am
parent61105df13b423b100394639cf7850856efbad767 (diff)
database: simple hashmap based database implementation
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index aa82d794..17011cd3 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -870,6 +870,9 @@ libpulsecore_@PA_MAJORMINORMICRO@_la_CFLAGS += $(TDB_CFLAGS)
libpulsecore_@PA_MAJORMINORMICRO@_la_LIBADD += $(TDB_LIBS)
endif
+if HAVE_SIMPLEDB
+libpulsecore_@PA_MAJORMINORMICRO@_la_SOURCES += pulsecore/database-simple.c
+endif
# We split the foreign code off to not be annoyed by warnings we don't care about
noinst_LTLIBRARIES = libpulsecore-foreign.la