summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorColin Guthrie <cguthrie@mandriva.org>2009-06-27 21:03:37 +0100
committerColin Guthrie <cguthrie@mandriva.org>2009-11-11 17:44:22 +0000
commit4c68fe7b9f176016e6f574d215f1db8546eaeb38 (patch)
tree49f2acf791191a146cfa7b1a2d3470fcb559dfe6 /src/Makefile.am
parenta79585e042088b73632a4773b2d3b59a7371611f (diff)
device-manager: Add a new module to keep track of the names and descriptions of various sinks.
This will be used as the basis for a queryable system for past and present devices, initially for use in KDE. Currently all this module does is save lists of sinks/sources and their descriptions, so it needs to gain a protocol extension to make this queryable. As things stand it will save the device descriptions of all sinks and restore them if they differ from whats on record.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am12
1 files changed, 10 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index de15a8f2..4e79fa7e 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -992,7 +992,8 @@ modlibexec_LTLIBRARIES += \
module-sine-source.la \
module-detect.la \
module-volume-restore.la \
- module-device-restore.la \
+ module-device-manager.la \
+ module-device-restore.la \
module-stream-restore.la \
module-card-restore.la \
module-default-device-restore.la \
@@ -1233,7 +1234,8 @@ SYMDEF_FILES = \
modules/jack/module-jack-sink-symdef.h \
modules/jack/module-jack-source-symdef.h \
modules/module-volume-restore-symdef.h \
- modules/module-device-restore-symdef.h \
+ modules/module-device-manager-symdef.h \
+ modules/module-device-restore-symdef.h \
modules/module-stream-restore-symdef.h \
modules/module-card-restore-symdef.h \
modules/module-default-device-restore-symdef.h \
@@ -1541,6 +1543,12 @@ module_cork_music_on_phone_la_LDFLAGS = $(MODULE_LDFLAGS)
module_cork_music_on_phone_la_LIBADD = $(AM_LIBADD) libpulsecore-@PA_MAJORMINORMICRO@.la libpulsecommon-@PA_MAJORMINORMICRO@.la libpulse.la
module_cork_music_on_phone_la_CFLAGS = $(AM_CFLAGS)
+# Device description restore module
+module_device_manager_la_SOURCES = modules/module-device-manager.c
+module_device_manager_la_LDFLAGS = $(MODULE_LDFLAGS)
+module_device_manager_la_LIBADD = $(AM_LIBADD) libpulsecore-@PA_MAJORMINORMICRO@.la libpulsecommon-@PA_MAJORMINORMICRO@.la libpulse.la
+module_device_manager_la_CFLAGS = $(AM_CFLAGS)
+
# Device volume/muted restore module
module_device_restore_la_SOURCES = modules/module-device-restore.c
module_device_restore_la_LDFLAGS = $(MODULE_LDFLAGS)