summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorPierre Ossman <ossman@cendio.se>2006-05-02 08:41:41 +0000
committerPierre Ossman <ossman@cendio.se>2006-05-02 08:41:41 +0000
commit1438bd49dc9bd5b7e57f9a75c6760ae769ee37bf (patch)
tree0f82b865bc51987f6d6002104bd2d2e2ea157610 /src/Makefile.am
parent9e60bad5c3cb938b250e04e2048fdc46353c5719 (diff)
Windows doesn't have POSIX thread. ifdef out things for now.
git-svn-id: file:///home/lennart/svn/public/pulseaudio/trunk@824 fefdeb5f-60dc-0310-8127-8f9354f1896f
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 8ad4859e..66e20af5 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -181,7 +181,6 @@ pabrowse_LDFLAGS = $(AM_LDFLAGS) $(BINLDFLAGS)
noinst_PROGRAMS = \
mainloop-test \
- thread-mainloop-test \
mcalign-test \
pacat-simple \
parec-simple \
@@ -207,6 +206,12 @@ noinst_PROGRAMS += \
mainloop-test-glib12
endif
+# FIXME: We need to make thread-mainloop win32-compatible first
+if !OS_IS_WIN32
+noinst_PROGRAMS += \
+ thread-mainloop-test
+endif
+
mainloop_test_SOURCES = tests/mainloop-test.c
mainloop_test_CFLAGS = $(AM_CFLAGS)
mainloop_test_LDADD = $(AM_LDADD) libpolyp-@PA_MAJORMINOR@.la