summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorPierre Ossman <ossman@cendio.se>2006-09-01 18:16:55 +0000
committerPierre Ossman <ossman@cendio.se>2006-09-01 18:16:55 +0000
commit3571bf1699d1fa42b5d24fcf62eea867f0fe9903 (patch)
tree3c5debdd8e5697b2955691a25454f8795cff6c42 /src/Makefile.am
parent97202d1b2d1638df147a369f4476060f608b568f (diff)
Thread implementation for Win32.
git-svn-id: file:///home/lennart/svn/public/pulseaudio/trunk@1356 fefdeb5f-60dc-0310-8127-8f9354f1896f
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am16
1 files changed, 13 insertions, 3 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 3b79acad..5043197c 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -580,6 +580,7 @@ libpulsecore_la_SOURCES += \
pulsecore/modargs.c pulsecore/modargs.h \
pulsecore/modinfo.c pulsecore/modinfo.h \
pulsecore/module.c pulsecore/module.h \
+ pulsecore/mutex.h \
pulsecore/namereg.c pulsecore/namereg.h \
pulsecore/pid.c pulsecore/pid.h \
pulsecore/pipe.c pulsecore/pipe.h \
@@ -602,19 +603,28 @@ libpulsecore_la_SOURCES += \
pulsecore/source.c pulsecore/source.h \
pulsecore/source-output.c pulsecore/source-output.h \
pulsecore/strbuf.c pulsecore/strbuf.h \
+ pulsecore/thread.h \
pulsecore/tokenizer.c pulsecore/tokenizer.h \
pulsecore/winsock.h \
pulsecore/core-error.c pulsecore/core-error.h \
pulsecore/hook-list.c pulsecore/hook-list.h \
- pulsecore/shm.c pulsecore/shm.h \
- pulsecore/mutex-posix.c pulsecore/mutex.h \
- pulsecore/thread-posix.c pulsecore/thread.h
+ pulsecore/shm.c pulsecore/shm.h
if OS_IS_WIN32
libpulsecore_la_SOURCES += \
pulsecore/dllmain.c
endif
+if OS_IS_WIN32
+libpulsecore_la_SOURCES += \
+ pulsecore/mutex-win32.c \
+ pulsecore/thread-win32.c
+else
+libpulsecore_la_SOURCES += \
+ pulsecore/mutex-posix.c \
+ pulsecore/thread-posix.c
+endif
+
libpulsecore_la_CPPFLAGS = $(AM_CPPFLAGS) $(LIBOIL_CFLAGS)
libpulsecore_la_LDFLAGS = -version-info $(LIBPULSECORE_VERSION_INFO)
libpulsecore_la_LIBADD = $(AM_LIBADD) $(LIBLTDL) $(LIBSAMPLERATE_LIBS) $(LIBSNDFILE_LIBS) $(WINSOCK_LIBS) $(LIBOIL_LIBS) $(LIBICONV)