summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorPierre Ossman <ossman@cendio.se>2006-05-11 11:08:58 +0000
committerPierre Ossman <ossman@cendio.se>2006-05-11 11:08:58 +0000
commit48d66cd5e89764b00fe225db4823b3392a759942 (patch)
tree0e60a5cf549d07f6be53e60fa83b355fd77a7094 /src/Makefile.am
parent12d4b5d952c7a284fd081966a02d34d94dd6be10 (diff)
Handle pipes on platforms where they are non-existant of broken.
We do this by creating a TCP socket pair instead of a normal pipe. Since Windows isn't UNIX-y enough to support read()/write() on sockets, we also need a wrapper to handle read() vs recv() and write() vs send(). git-svn-id: file:///home/lennart/svn/public/pulseaudio/trunk@840 fefdeb5f-60dc-0310-8127-8f9354f1896f
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index ee7b2325..72e3c1eb 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -356,6 +356,7 @@ libpolyp_@PA_MAJORMINOR@_la_SOURCES = \
polyp/mainloop.c polyp/mainloop.h \
polyp/mainloop-signal.c polyp/mainloop-signal.h \
polyp/thread-mainloop.c polyp/thread-mainloop.h \
+ polypcore/pipe.c polypcore/pipe.h \
polypcore/poll.c polypcore/poll.h
# Internal stuff that is shared with libpolypcore
@@ -518,6 +519,7 @@ libpolypcore_la_SOURCES += \
polypcore/module.c polypcore/module.h \
polypcore/namereg.c polypcore/namereg.h \
polypcore/pid.c polypcore/pid.h \
+ polypcore/pipe.c polypcore/pipe.h \
polypcore/play-memchunk.c polypcore/play-memchunk.h \
polypcore/poll.c polypcore/poll.h \
polypcore/props.c polypcore/props.h \