summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorMichael Terry <michael.terry@canonical.com>2011-04-03 13:42:44 +0100
committerColin Guthrie <colin@mageia.org>2011-04-03 13:42:44 +0100
commit6ed3a7dcc9de81469c5d35a5256e5f50bd48f804 (patch)
treeea1e28d034397f811a0ca282bcc0351e4a6e89a2 /src/Makefile.am
parentc083259464e1e140165795a8bf6e3c0cfcbc64fe (diff)
switch-on-connect: Add a new module to allow for hotplugged devices to be used by default.
This module implements a simply policy decision that any newly plugged in devices should be used. This is a reasonable approach and paprefs will be updated to allow for this option to be turned on or off. This is more or less a stop-gap solution. When priority lists are implemented in the core, then policy modules may ultimately be re-engineered to adjust the priority lists rather than doing any of their own routing per-se.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am10
1 files changed, 8 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index bdeddedd..dc2a1cd6 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1051,7 +1051,8 @@ modlibexec_LTLIBRARIES += \
module-cork-music-on-phone.la \
module-loopback.la \
module-virtual-sink.la \
- module-virtual-source.la
+ module-virtual-source.la \
+ module-switch-on-connect.la
# See comment at librtp.la above
if !OS_IS_WIN32
@@ -1338,7 +1339,8 @@ SYMDEF_FILES = \
module-dbus-protocol-symdef.h \
module-loopback-symdef.h \
module-virtual-sink-symdef.h \
- module-virtual-source-symdef.h
+ module-virtual-source-symdef.h \
+ module-switch-on-connect-symdef.h
EXTRA_DIST += $(SYMDEF_FILES)
BUILT_SOURCES += $(SYMDEF_FILES) builddirs
@@ -1480,6 +1482,10 @@ module_combine_la_SOURCES = modules/module-combine.c
module_combine_la_LDFLAGS = $(MODULE_LDFLAGS)
module_combine_la_LIBADD = $(MODULE_LIBADD)
+module_switch_on_connect_la_SOURCES = modules/module-switch-on-connect.c
+module_switch_on_connect_la_LDFLAGS = $(MODULE_LDFLAGS)
+module_switch_on_connect_la_LIBADD = $(MODULE_LIBADD)
+
module_remap_sink_la_SOURCES = modules/module-remap-sink.c
module_remap_sink_la_LDFLAGS = $(MODULE_LDFLAGS)
module_remap_sink_la_LIBADD = $(MODULE_LIBADD)