summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2009-03-01 20:34:07 +0100
committerLennart Poettering <lennart@poettering.net>2009-03-01 21:38:22 +0100
commit784ac5b0da4f510232166406b3166fba0bef58e4 (patch)
treeb46c92114f90ed796729d978001ebc14c8481202 /src/Makefile.am
parentcc8d51ad629891b5eb6b355c999c1c1b7e3fb34e (diff)
get additional device data from udev
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index f5a1febe..9f2fa02a 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1313,6 +1313,12 @@ libalsa_util_la_LIBADD += $(HAL_LIBS)
libalsa_util_la_CFLAGS += $(HAL_CFLAGS)
endif
+if HAVE_UDEV
+libalsa_util_la_SOURCES += modules/udev-util.h modules/udev-util.c
+libalsa_util_la_LIBADD += $(UDEV_LIBS)
+libalsa_util_la_CFLAGS += $(UDEV_CFLAGS)
+endif
+
if HAVE_DBUS
libalsa_util_la_SOURCES += modules/reserve.h modules/reserve.c modules/reserve-wrap.c modules/reserve-wrap.h
libalsa_util_la_LIBADD += $(DBUS_LIBS) libdbus-util.la