summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2008-07-30 16:59:30 +0200
committerLennart Poettering <lennart@poettering.net>2008-07-30 16:59:30 +0200
commit881046b730125cdb24a5bd8fac9d18901c66b523 (patch)
treecf889569ca2684081f29ffc17a005098362de86d /src/Makefile.am
parent90569d37a03b1b0cfcb9dbe0a431184c873e7481 (diff)
install a default system.pa
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 98d06aa8..36bfdcab 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -96,6 +96,7 @@ EXTRA_DIST = \
pulse/version.h.in \
daemon/daemon.conf.in \
daemon/default.pa.in \
+ daemon/system.pa.in \
daemon/default.pa.win32 \
depmod.py \
daemon/esdcompat.in \
@@ -108,6 +109,7 @@ EXTRA_DIST = \
pulseconf_DATA = \
default.pa \
+ system.pa \
daemon.conf \
client.conf
@@ -1543,7 +1545,7 @@ suid: pulseaudio .libs/lt-pulseaudio
chown root $^
chmod u+s $^
-CLEANFILES = esdcompat client.conf default.pa daemon.conf start-pulseaudio-x11
+CLEANFILES = esdcompat client.conf default.pa system.pa daemon.conf start-pulseaudio-x11
esdcompat: daemon/esdcompat.in Makefile
sed -e 's,@PACKAGE_VERSION\@,$(PACKAGE_VERSION),g' \
@@ -1562,11 +1564,17 @@ client.conf: pulse/client.conf.in Makefile
if OS_IS_WIN32
default.pa: daemon/default.pa.win32
cp $< $@
+system.pa: daemon/default.pa.win32
+ cp $< $@
else
default.pa: daemon/default.pa.in Makefile
sed -e 's,@PA_BINARY\@,$(PA_BINARY),g' \
-e 's,@PA_DLSEARCHPATH\@,$(modlibexecdir),g' \
-e 's,@PA_SOEXT\@,.so,g' < $< > $@
+system.pa: daemon/system.pa.in Makefile
+ sed -e 's,@PA_BINARY\@,$(PA_BINARY),g' \
+ -e 's,@PA_DLSEARCHPATH\@,$(modlibexecdir),g' \
+ -e 's,@PA_SOEXT\@,.so,g' < $< > $@
endif
daemon.conf: daemon/daemon.conf.in Makefile