summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2009-01-19 23:09:58 +0100
committerLennart Poettering <lennart@poettering.net>2009-01-19 23:09:58 +0100
commit96f01bf73fb8321f7dde732ab1b7ce52b5121043 (patch)
tree1b3bcbac77c87c1bf8616dd1ac750003c18f490e /src/Makefile.am
parent5f6641cfdd49d64b1cbc68ed025f9d22edc2665c (diff)
parent7104d54bbce8f9bd2553e16f45f3a0f69ac75b8b (diff)
Merge commit '7104d54bbce8f9bd2553e16f45f3a0f69ac75b8b'
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am10
1 files changed, 6 insertions, 4 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 839cce09..e8f0a820 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -47,10 +47,15 @@ endif
AM_CFLAGS = \
-I$(top_srcdir)/src \
+ -I$(top_builddir)/src \
-I$(top_srcdir)/src/modules \
+ -I$(top_builddir)/src/modules \
-I$(top_srcdir)/src/modules/rtp \
+ -I$(top_builddir)/src/modules/rtp \
-I$(top_srcdir)/src/modules/gconf \
+ -I$(top_builddir)/src/modules/gconf \
-I$(top_srcdir)/src/modules/bluetooth \
+ -I$(top_builddir)/src/modules/bluetooth \
-I$(top_srcdir)/src/modules/raop \
$(PTHREAD_CFLAGS) -D_POSIX_PTHREAD_SEMANTICS \
$(LTDLINCL) \
@@ -1070,10 +1075,7 @@ EXTRA_DIST += $(SYMDEF_FILES)
BUILT_SOURCES += $(SYMDEF_FILES)
$(SYMDEF_FILES): modules/module-defs.h.m4
- $(MKDIR_P) modules
- $(MKDIR_P) modules/gconf
- $(MKDIR_P) modules/rtp
- $(MKDIR_P) modules/bluetooth
+ $(MKDIR_P) $(dir $@)
$(M4) -Dfname="$@" $< > $@
# Flat volume