summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2009-02-12 03:19:40 +0100
committerLennart Poettering <lennart@poettering.net>2009-02-12 03:19:40 +0100
commita729786637ddcccf41591c74eca357a8e8a63f2c (patch)
tree4114ea5052fa9da4f6b83e5cf48571668fb9404a /src/Makefile.am
parent823431e44732a0824658c82de29aaa92f8f39f79 (diff)
implement a module that corks music/video streams automatically when a phone call is active
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index ca8240f1..fc478037 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -896,7 +896,8 @@ modlibexec_LTLIBRARIES += \
module-tunnel-sink.la \
module-tunnel-source.la \
module-position-event-sounds.la \
- module-augment-properties.la
+ module-augment-properties.la \
+ module-cork-music-on-phone.la
# See comment at librtp.la above
@@ -1086,6 +1087,7 @@ SYMDEF_FILES = \
modules/gconf/module-gconf-symdef.h \
modules/module-position-event-sounds-symdef.h \
modules/module-augment-properties-symdef.h \
+ modules/module-cork-music-on-phone-symdef.h \
modules/module-console-kit-symdef.h
EXTRA_DIST += $(SYMDEF_FILES)
@@ -1347,6 +1349,12 @@ module_augment_properties_la_LIBADD = $(AM_LIBADD) libpulsecore-@PA_MAJORMINORMI
#module_augment_properties_la_CFLAGS = $(AM_CFLAGS) -DDESKTOPFILEDIR=\"$(datadir)/applications\"
module_augment_properties_la_CFLAGS = $(AM_CFLAGS) -DDESKTOPFILEDIR=\"/usr/share/applications\"
+# Cork music streams while a phone stream is active
+module_cork_music_on_phone_la_SOURCES = modules/module-cork-music-on-phone.c
+module_cork_music_on_phone_la_LDFLAGS = $(MODULE_LDFLAGS)
+module_cork_music_on_phone_la_LIBADD = $(AM_LIBADD) libpulsecore-@PA_MAJORMINORMICRO@.la libpulsecommon-@PA_MAJORMINORMICRO@.la libpulse.la
+module_cork_music_on_phone_la_CFLAGS = $(AM_CFLAGS)
+
# Device volume/muted restore module
module_device_restore_la_SOURCES = modules/module-device-restore.c
module_device_restore_la_LDFLAGS = $(MODULE_LDFLAGS)