summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorMarc-André Lureau <marcandre.lureau@gmail.com>2009-01-08 18:25:12 +0200
committerMarc-André Lureau <marcandre.lureau@gmail.com>2009-01-08 19:16:59 +0200
commitd096ad78d35156cb61f5c2aee4bb3f58a055da56 (patch)
tree1191779d03781a6c6bb36840f8e1879727dbc77c /src/Makefile.am
parent8e200ed0ce071cba686251b42cdbc5356f8fee75 (diff)
bluetooth: add update-sbc and friends
Grr.. You can't do: SBC_FILES = a b c libsbc_SOURCES = $(addprefix modules/bluetooth/,$(SBC_FILES)) With automake... So I $(strip 'modules/bluetooth/') instead.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index e4ec4880..608e6786 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1415,6 +1415,7 @@ libbluetooth_sbc_la_SOURCES = modules/bluetooth/sbc.c modules/bluetooth/sbc.h mo
libbluetooth_sbc_la_LDFLAGS = -avoid-version
libbluetooth_sbc_la_LIBADD = $(AM_LIBADD) libpulsecore-@PA_MAJORMINORMICRO@.la libpulsecommon-@PA_MAJORMINORMICRO@.la libpulse.la
libbluetooth_sbc_la_CFLAGS = $(AM_CFLAGS)
+SBC_FILES = $(subst modules/bluetooth/,,$(libbluetooth_sbc_la_SOURCES))
libbluetooth_ipc_la_SOURCES = modules/bluetooth/ipc.c modules/bluetooth/ipc.h
libbluetooth_ipc_la_LDFLAGS = -avoid-version
@@ -1500,6 +1501,11 @@ massif: pulseaudio
update-ffmpeg:
wget -O pulsecore/ffmpeg/resample2.c http://svn.mplayerhq.hu/ffmpeg/trunk/libavcodec/resample2.c?view=co
+update-sbc:
+ for i in $(SBC_FILES); do \
+ wget -O modules/bluetooth/$$i http://git.kernel.org/\?p=bluetooth/bluez.git\;a=blob_plain\;f=sbc/$$i ; \
+ done
+
# Automatically generate linker version script. We use the same one for all public .sos
update-map-file:
( echo "PULSE_0 {" ; \
@@ -1509,4 +1515,6 @@ update-map-file:
echo "*;" ; \
echo "};" ) > $(srcdir)/map-file
-.PHONY: utils/padsp
+update-all: update-ffmpeg update-sbc update-map-file
+
+.PHONY: utils/padsp massif update-all update-ffmpeg update-sbc update-map-file