summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorHenning Heinold <heinold@inf.fu-berlin.de>2009-07-10 12:33:30 +0200
committerColin Guthrie <cguthrie@mandriva.org>2011-02-22 09:59:42 +0000
commitd90be0347475cfa5ed051c99ddd2ee10d10c7d05 (patch)
treeb8373bf1830e3fe19f2c716034d3de8bab783cc7 /src/Makefile.am
parentbada9040dddcf666773d32177949635c02f4f51f (diff)
src/Makefile.am: add missing space to fix build using uClibc
Using uClibc AM_LIBADD = $(PTHREAD_LIBS) $(INTLLIBS) is not empty because `$(INTLLIBS)` is set to `-lintl`. This uncovered a missing space in commit ef0cc745 which resulted in the following build error. […] CC libbluetooth_ipc_la-ipc.lo modules/bluetooth/ipc.c: In function 'bt_audio_service_open': modules/bluetooth/ipc.c:65:26: warning: dereferencing type-punned pointer might break strict-aliasing rules [-Wstrict-aliasing] modules/bluetooth/ipc.c: In function 'bt_audio_service_get_data_fd': modules/bluetooth/ipc.c:110:13: warning: cast increases required alignment of target type [-Wcast-align] modules/bluetooth/ipc.c:110:4: warning: dereferencing type-punned pointer will break strict-aliasing rules [-Wstrict-aliasing] make[3]: *** No rule to make target `-lintl', needed by `libbluetooth-ipc.la'. Stop. make[3]: Leaving directory `/oe/build-minimal-uclibc/minimal-uclibc-dev/work/armv7a-oe-linux-uclibceabi/pulseaudio-0.9.22-r11.0+gitr0+051d82133f0ae6a57bf66fd200bc8e3591a7d5ca/git/src' make[2]: *** [all] Error 2 make[2]: Leaving directory `/oe/build-minimal-uclibc/minimal-uclibc-dev/work/armv7a-oe-linux-uclibceabi/pulseaudio-0.9.22-r11.0+gitr0+051d82133f0ae6a57bf66fd200bc8e3591a7d5ca/git/src' make[1]: *** [all-recursive] Error 1 make[1]: Leaving directory `/oe/build-minimal-uclibc/minimal-uclibc-dev/work/armv7a-oe-linux-uclibceabi/pulseaudio-0.9.22-r11.0+gitr0+051d82133f0ae6a57bf66fd200bc8e3591a7d5ca/git' make: *** [all] Error 2 This patch is taken from OpenEmbedded where it has been present since 2009 for PulseAudio 0.9.15 and greater [1]. [1] http://git.0pointer.de/?p=pulseaudio.git;a=commit;h=ef0cc74567b3bb98378c17f6a523bf18ba132ed7 [2] http://cgit.openembedded.org/cgit.cgi/openembedded/commit/?id=7c33f2e906a20e139d53b4f2d8fbc2773a4725b3 Signed-off-by: Henning Heinold <heinold@inf.fu-berlin.de> Signed-off-by: Paul Menzel <paulepanter@users.sourceforge.net> CC: Henning Heinold <heinold@inf.fu-berlin.de>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 0687e409..0ee7abc1 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1804,7 +1804,7 @@ BLUETOOTH_SBC_FILES = $(subst modules/bluetooth/,,$(libbluetooth_sbc_la_SOURCES)
libbluetooth_ipc_la_SOURCES = modules/bluetooth/ipc.c modules/bluetooth/ipc.h
libbluetooth_ipc_la_LDFLAGS = -avoid-version
-libbluetooth_ipc_la_LIBADD = $(AM_LIBADD)libpulsecore-@PA_MAJORMINOR@.la libpulsecommon-@PA_MAJORMINOR@.la libpulse.la
+libbluetooth_ipc_la_LIBADD = $(AM_LIBADD) libpulsecore-@PA_MAJORMINOR@.la libpulsecommon-@PA_MAJORMINOR@.la libpulse.la
libbluetooth_ipc_la_CFLAGS = $(AM_CFLAGS)
BLUETOOTH_IPC_FILES = $(subst modules/bluetooth/,,$(libbluetooth_ipc_la_SOURCES)) rtp.h