summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2006-04-16 00:16:53 +0000
committerLennart Poettering <lennart@poettering.net>2006-04-16 00:16:53 +0000
commitf1ddf052368ad96cf157297a50ffe52ee8f7ca39 (patch)
treedad94d135aeaa6b78adecbf208ffc0ef03a59acb /src/Makefile.am
parent1fec416db7db4ba8d2d2dd250187939f0b06dbd7 (diff)
* add RTP/SAP/SDP reciever module
* use server cookie as RTP SSRC * enable SVN keywords * add new option "loop" for RTP sender module git-svn-id: file:///home/lennart/svn/public/pulseaudio/trunk@716 fefdeb5f-60dc-0310-8127-8f9354f1896f
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am13
1 files changed, 10 insertions, 3 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index f23778d0..2ec62dca 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -722,7 +722,8 @@ modlib_LTLIBRARIES += \
module-esound-sink.la \
module-http-protocol-tcp.la \
module-detect.la \
- module-rtp-monitor.la
+ module-rtp-monitor.la \
+ module-rtp-recv.la
if HAVE_AF_UNIX
modlib_LTLIBRARIES += \
@@ -834,7 +835,8 @@ SYMDEF_FILES = \
modules/module-solaris-symdef.h \
modules/module-waveout-symdef.h \
modules/module-detect-symdef.h \
- modules/rtp/module-rtp-monitor-symdef.h
+ modules/rtp/module-rtp-monitor-symdef.h \
+ modules/rtp/module-rtp-recv-symdef.h
EXTRA_DIST += $(SYMDEF_FILES)
BUILT_SOURCES += $(SYMDEF_FILES)
@@ -1049,12 +1051,17 @@ module_detect_la_LDFLAGS = -module -avoid-version
module_detect_la_LIBADD = $(AM_LIBADD) libpolypcore.la
module_detect_la_CFLAGS = $(AM_CFLAGS)
-# Hardware autodetection module
+# RTP modules
module_rtp_monitor_la_SOURCES = modules/rtp/module-rtp-monitor.c
module_rtp_monitor_la_LDFLAGS = -module -avoid-version
module_rtp_monitor_la_LIBADD = $(AM_LIBADD) libpolypcore.la
module_rtp_monitor_la_CFLAGS = $(AM_CFLAGS)
+module_rtp_recv_la_SOURCES = modules/rtp/module-rtp-recv.c
+module_rtp_recv_la_LDFLAGS = -module -avoid-version
+module_rtp_recv_la_LIBADD = $(AM_LIBADD) libpolypcore.la
+module_rtp_recv_la_CFLAGS = $(AM_CFLAGS)
+
###################################
# Some minor stuff #
###################################