summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index a8a9eaac..ca43de10 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -72,8 +72,8 @@ fedora-snapshot: dist
dist-hook:
if test -d .git ; then \
- test -z $$SKIP_GIT && git pull ; \
- chmod u+w ${distdir}/ChangeLog || true ; \
+ test -z $$USE_GIT || git pull ; \
+ test -f ${distdir}/ChangeLog && chmod u+w ${distdir}/ChangeLog ; \
( git-changelog.perl || echo "git-changelog.perl failed." ) > ${distdir}/ChangeLog 2>&1 ; \
fi
echo $(VERSION) > $(distdir)/.tarball-version