summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 16 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index e08c11c1..07db9823 100644
--- a/configure.ac
+++ b/configure.ac
@@ -39,12 +39,27 @@ AC_SUBST(PACKAGE_URL, [http://pulseaudio.org/])
AC_SUBST(PA_API_VERSION, 10)
AC_SUBST(PA_PROTOCOL_VERSION, 11)
+# The stable ABI for client applications, for the version info x:y:z
+# always will hold y=z
AC_SUBST(LIBPULSE_VERSION_INFO, [3:0:3])
-AC_SUBST(LIBPULSECORE_VERSION_INFO, [4:0:0])
+
+# A simplified, synchronous, ABI-stable interface for client
+# applications, for the version info x:y:z always will hold y=z
AC_SUBST(LIBPULSE_SIMPLE_VERSION_INFO, [0:1:0])
+
+# The ABI-stable network browsing interface for client applications,
+# for the version info x:y:z always will hold y=z
AC_SUBST(LIBPULSE_BROWSE_VERSION_INFO, [1:1:1])
+
+# The ABI-stable GLib adapter for client applications, for the version
+# info x:y:z always will hold y=z
AC_SUBST(LIBPULSE_MAINLOOP_GLIB_VERSION_INFO, [0:3:0])
+# An internally used, ABI-unstable library that contains the
+# PulseAudio core, SONAMEs are bumped on every release, version info
+# suffix will always be 0:0
+AC_SUBST(LIBPULSECORE_VERSION_INFO, [4:0:0])
+
AC_CANONICAL_HOST
if type -p stow > /dev/null && test -d /usr/local/stow ; then