summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 33b305e7..42bee9a8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -320,6 +320,18 @@ PKG_CHECK_MODULES(LIBSNDFILE, [ sndfile >= 1.0.10 ])
AC_SUBST(LIBSNDFILE_CFLAGS)
AC_SUBST(LIBSNDFILE_LIBS)
+#### atomic-ops ###
+
+AC_CHECK_HEADERS([atomic_ops.h], [], [
+AC_MSG_ERROR([*** libatomic-ops headers not found])
+])
+
+AC_SEARCH_LIBS([AO_spin], [atomic_ops], [], [
+AC_MSG_ERROR([*** libatomic-ops library file not found])
+])
+
+
+
#### OSS support (optional) ####
AC_ARG_ENABLE([oss],