summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 7d7f8f73..6511137e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -398,6 +398,12 @@ if test "x$PREOPEN_MODS" != "xall" ; then
AC_SUBST(PREOPEN_MODS)
fi
+AC_ARG_ENABLE(
+ [force-preopen],
+ AC_HELP_STRING([--enable-force-preopen],[Preopen modules, even when dlopen() is supported.]),
+ [FORCE_PREOPEN=1], [FORCE_PREOPEN=0])
+AM_CONDITIONAL([FORCE_PREOPEN], [test "x$FORCE_PREOPEN" = "x1"])
+
AC_CONFIG_FILES([
Makefile
src/Makefile