summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 19 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index db73d91c..a35bef83 100644
--- a/configure.ac
+++ b/configure.ac
@@ -537,6 +537,25 @@ AC_SUBST(X11_LIBS)
AC_SUBST(HAVE_X11)
AM_CONDITIONAL([HAVE_X11], [test "x$HAVE_X11" = x1])
+#### Capabilities (optional) ####
+
+CAP_LIBS=''
+
+AC_ARG_WITH(
+ [caps],
+ AS_HELP_STRING([--without-caps],[Omit support for POSIX capabilities.]))
+
+if test "x${with_caps}" != "xno"; then
+ AC_SEARCH_LIBS([cap_init], [cap], [], [
+ if test "x${with_caps}" = "xyes" ; then
+ AC_MSG_ERROR([*** POSIX caps libraries not found])
+ fi])
+ AC_CHECK_HEADERS([sys/capability.h], [], [
+ if test "x${with_caps}" = "xyes" ; then
+ AC_MSG_ERROR([*** POSIX caps headers not found])
+ fi])
+fi
+
#### Valgrind (optional) ####
AC_CHECK_HEADERS_ONCE([valgrind/memcheck.h])