summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am12
1 files changed, 9 insertions, 3 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index e8f0a820..fbe9e914 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -253,7 +253,7 @@ TESTS = \
lock-autospawn-test \
prioq-test
-noinst_PROGRAMS = \
+TESTS_BINARIES = \
mainloop-test \
mcalign-test \
pacat-simple \
@@ -293,7 +293,7 @@ if HAVE_SIGXCPU
#TESTS += \
# cpulimit-test \
# cpulimit-test2
-noinst_PROGRAMS += \
+TESTS_BINARIES += \
cpulimit-test \
cpulimit-test2
endif
@@ -301,10 +301,16 @@ endif
if HAVE_GLIB20
TESTS += \
mainloop-test-glib
-noinst_PROGRAMS += \
+TESTS_BINARIES += \
mainloop-test-glib
endif
+if BUILD_TESTS_DEFAULT
+noinst_PROGRAMS = $(TESTS_BINARIES)
+else
+check_PROGRAMS = $(TESTS_BINARIES)
+endif
+
mainloop_test_SOURCES = tests/mainloop-test.c
mainloop_test_CFLAGS = $(AM_CFLAGS)
mainloop_test_LDADD = $(AM_LDADD) libpulse.la