summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac28
1 files changed, 28 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..8ca6659
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,28 @@
+AC_PREREQ(2.57)
+AC_INIT([service-discovery-applet], [0.1], [sebastien (dot) estienne (at) gmail (dot) com])
+AC_CONFIG_SRCDIR([src/service-discovery-applet.in])
+AC_CONFIG_HEADERS([config.h])
+AM_INIT_AUTOMAKE([foreign 1.9 -Wall])
+
+AM_MAINTAINER_MODE
+
+AM_PATH_PYTHON([2.4])
+AM_CHECK_PYMOD(gtk,,,[AC_MSG_ERROR(Could not find Python module pygtk)])
+AM_CHECK_PYMOD(dbus,,,[AC_MSG_ERROR(Could not find Python module dbus)])
+AM_CHECK_PYMOD(avahi,,,[AC_MSG_ERROR(Could not find Python module avahi)])
+
+SCRIPTSDIR="${datadir}/${PACKAGE}/scripts/"
+AC_SUBST(SCRIPTSDIR)
+ICONSDIR="${datadir}/${PACKAGE}/icons/"
+AC_SUBST(ICONSDIR)
+
+
+AC_CONFIG_FILES([
+ Makefile
+ common/Makefile
+ src/Makefile
+ icons/Makefile
+ scripts/Makefile
+ servers/Makefile
+])
+AC_OUTPUT