summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index df2fa4a..c914f22 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4,6 +4,8 @@ AC_CONFIG_SRCDIR([src/service-discovery-applet.in])
AM_INIT_AUTOMAKE([foreign 1.9 -Wall])
AC_CONFIG_MACRO_DIR([common])
+AC_PROG_INTLTOOL([0.21])
+
AC_SUBST(VERSION)
AM_MAINTAINER_MODE
@@ -42,6 +44,19 @@ dnl ========================================================
AM_GCONF_SOURCE_2
dnl ========================================================
+dnl This is for gettext support
+dnl ========================================================
+GETTEXT_PACKAGE=service-discovery-applet
+AC_DEFINE_UNQUOTED(GETTEXT_PACKAGE,"$GETTEXT_PACKAGE", [Gettext package])
+AC_SUBST(GETTEXT_PACKAGE)
+ALL_LINGUAS="de"
+AM_GLIB_GNU_GETTEXT
+
+AM_GLIB_DEFINE_LOCALEDIR([LOCALEDIR])
+LOCALEDIR=$localedir
+AC_SUBST(LOCALEDIR)
+
+dnl ========================================================
AC_CONFIG_FILES([
Makefile
common/Makefile
@@ -53,6 +68,7 @@ AC_CONFIG_FILES([
actions/Makefile
actions/services/Makefile
src/Makefile
+ po/Makefile.in
])
AC_OUTPUT