summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorWilliam Jon McCann <mccann@jhu.edu>2006-11-17 17:33:22 -0500
committerWilliam Jon McCann <mccann@jhu.edu>2006-11-17 17:33:22 -0500
commitc05a0ed330836b4f9569b6b6c96d853b8207c33a (patch)
treedea80c0fc258f7ecc48ffad0fbe50ff25e9a14fe /Makefile.am
parentbabc733eff30a2be18fa3f99bc3ef4f14e35d259 (diff)
Automatically generate ChangeLog. Fix autogen. Remove translation stuff.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am26
1 files changed, 19 insertions, 7 deletions
diff --git a/Makefile.am b/Makefile.am
index 7e75475..d67905f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -8,7 +8,6 @@ SUBDIRS = \
src \
tools \
data \
- po \
$(NULL)
EXTRA_DIST = \
@@ -17,15 +16,9 @@ EXTRA_DIST = \
INSTALL \
README \
NEWS \
- intltool-extract.in \
- intltool-merge.in \
- intltool-update.in \
$(NULL)
DISTCLEANFILES = \
- intltool-extract \
- intltool-merge \
- intltool-update \
$(NULL)
MAINTAINERCLEANFILES = \
@@ -46,3 +39,22 @@ MAINTAINERCLEANFILES = \
aclocal.m4 \
$(NULL)
+# Creating ChangeLog from git log (taken from cairo/Makefile.am):
+
+ChangeLog: $(srcdir)/ChangeLog
+
+$(srcdir)/ChangeLog:
+ @if test -d "$(srcdir)/.git"; then \
+ (cd "$(srcdir)" && \
+ ./missing --run git-log --stat) | fmt --split-only > $@.tmp \
+ && mv -f $@.tmp $@ \
+ || ($(RM) $@.tmp; \
+ echo Failed to generate ChangeLog, your ChangeLog may be outdated >&2; \
+ (test -f $@ || echo git-log is required to generate this file >> $@)); \
+ else \
+ test -f $@ || \
+ (echo A git checkout and git-log is required to generate ChangeLog >&2 && \
+ echo A git checkout and git-log is required to generate this file >> $@); \
+ fi
+
+.PHONY: ChangeLog $(srcdir)/ChangeLog